Known Issue 3 docked CVs + 1 docked HV disappeared after warping

Discussion in 'Known Issues' started by RedScourge, Jul 5, 2022.

  1. RedScourge

    RedScourge Commander

    Joined:
    Feb 12, 2016
    Messages:
    148
    Likes Received:
    89
    Note: I cannot select the NEW prefix as instructed in the README thread, it is not visible in the dropdown.

    Build: 3849
    Mode: Survival, MP Server

    SERVER NAME: Space Cowboys RE 1.8
    SEED-ID: 69420

    If applicable:
    MODIFIED PLAYFIELDS: Reforged Eden custom scenario defaults, but with star count reduced by ~55% to reduce server load

    Reproducibility: very rare
    Severity: high

    Type: Ships despawning

    Summary: A player was warping between space sectors in the same system and suddenly all of their docked vessels disappeared during or briefly after a warp jump, and they were found to have despawned at or before the server restart+backup less than 15 minutes later. I suspect some sort of docking bug in combination with some sort of flaw in server-side garbage collection may be to blame.

    Description:

    The affected player was flying a CV which had 3 CVs and 1 HV docked at the time, all were deleted. The player reported that their docked ships had disappeared at 2:50pm server local time, though the data columns in EAH Structures tab appear to indicate that the event occurred at 2:45pm server local time (America/Edmonton) about 15 mins before the server restarted for a backup. The equivalent time in the logs in UTC time would be 05-20:45:45.XXX. The admin noticed just moments before the restart+backup in the EAH (full) Structures list that the affected ships' Touched and Last Warp columns specified the above mentioned time, and an empty Deleted (the 1900-01-01 date or whatever), and their Docked To column all specified the ship they had been docked to. The admin was not able to establish if the "A" column was unchecked before the server restart, as it occurred as they were investigating and EAH froze as it usually does during a backup, but they were certainly all unchecked in the "A" column, denoting that they were removed by the server, after the restart.

    Server specifics at time of incident:

    Players online at the time: 1-2
    Structure Activity Log: Enabled
    Reserved Playfields: 3
    Stop Period: 0
    Restart Schedule: Twice daily, 3:00am, 3:00pm
    OS: Windows 10 Professional x64
    Memory: 32GB DDR4-2400
    CPU: AMD Ryzen 7 1700 8 core / 16 thread
    OS Storage: Samsung SSD 980 NVMe 1 TB
    Dedicated Server Storage: Samsung SSD 860 Evo 250GB

    Steps to Reproduce:
    1) dock ships
    2) warp around
    3) ships either get deleted or not (extremely rare)

    Screenshots, Crash Logs, any other Relevant Information or Download links:

    Attached is a copy of all playfield and dedicated logs, grouped by the ones taken before the restart+backup and the ones taken after the restart+backup. Note that the event occurred at 2:45pm local time, roughly 15 mins before server restart+backup.
     

    Attached Files:

    #1
    Last edited: Jul 6, 2022

Share This Page