Bug Reports: Alpha 5.4.x

Discussion in 'Bugs' started by EleonGameStudios, Feb 16, 2017.

Thread Status:
Not open for further replies.
  1. pyhfol

    pyhfol Ensign

    Joined:
    Jan 31, 2017
    Messages:
    2
    Likes Received:
    2
    Mode: Survival
    Location: Dedicated Server

    SERVER NAME: GSG Perth AUS - Vanilla - Active Admin
    SEED-ID: 19866969

    If applicable:
    MODIFIED PLAYFIELDS: No - Although an attempt was made after issues were first reported, Sectors.yaml was replaced with original.

    Reproducibility: Always
    Severity: Major

    Summary:
    Since 5.4 players are reporting that
    A: They are unable to warp to another system
    B: They are unable to enter space from the surface of a planet

    Description:
    A: When attempting to jump to another playfield, no jump is made, however fuel is still consumed.
    B: Players report that when trying to leave the surface, they get to the barrier where usually playfield would change, and are then returned to the surface of the planet.
    As server admin I am also noticing playfield crashes which I have included below.
    Server has been running fine since early Feb. The server IS under spec, however has not any any other issues until 5.4. Server is due to move to a better platform in the coming days.

    Steps to Reproduce:
    Attempt to warp to another system or leave the planet surface

    Screenshots, Crash Logs, any other Relevant Information:
    See attached Server & Crash logs
    I have asked players for more information and will update this post accordingly.
     

    Attached Files:

    #81
    Tyrax Lightning likes this.
  2. Tyrax Lightning

    Tyrax Lightning Rear Admiral

    Joined:
    Jan 20, 2016
    Messages:
    4,789
    Likes Received:
    3,604
    That can definitely be the problem as well. Companies do NOT get along with each other & Cooperate with their Code with each other if they don't have an Alliance with each other, instead Competing Code tends to fight each other trying to make YOU use ONLY them & no one else so only THAT Company & no other gets your Money. :/
     
    #82
  3. Pantera

    Pantera Rear Admiral

    Joined:
    Aug 15, 2016
    Messages:
    1,877
    Likes Received:
    1,639
    This is about the jetpack in the left speaker only when you have something equipped right ?

    Its fixed on experimental fyi.
     
    #83
    Tyrax Lightning likes this.
  4. snack95

    snack95 Lieutenant

    Joined:
    Dec 21, 2016
    Messages:
    82
    Likes Received:
    9
    Mode: Survival
    Location: Dedicated Server

    SERVER NAME: [FR] The World

    If applicable:
    MODIFIED PLAYFIELDS: Yes But the problem is on all planets

    Reproducibility: Sometimes
    Severity: Major

    Summary:
    - Sometimes the constructor does not work, It blocks and does not build more (see image)
    - And another bug ... sometimes we can not rattle in the chat (see image)
    - Sometimes we can not get out of the planet, whenever we pass the atmosphere it returns us back

    Sorry for my english ^^
     

    Attached Files:

    #84
    Rappeldrache and Tyrax Lightning like this.
  5. Tyrax Lightning

    Tyrax Lightning Rear Admiral

    Joined:
    Jan 20, 2016
    Messages:
    4,789
    Likes Received:
    3,604
    Ya'd have to point that to the Issue Haver, @Cpt_Beefheart & see if it's resolved for him.
     
    #85
    Pantera likes this.
  6. Pantera

    Pantera Rear Admiral

    Joined:
    Aug 15, 2016
    Messages:
    1,877
    Likes Received:
    1,639
    I don't think @Cpt_Beefheart is on experimental judging by the screenshots posted 1 page back. Will have to wait to see the reply to this I suppose.
     
    #86
    Tyrax Lightning likes this.
  7. Rappeldrache

    Rappeldrache Lieutenant

    Joined:
    Feb 8, 2017
    Messages:
    18
    Likes Received:
    30
    Hello "Hummel" :) nice nickname *g*

    here everything is working again. Plants are growing. :) Faction seem to work.

    Greetings& Hugs
     
    #87
    Tyrax Lightning likes this.
  8. Cpt_Beefheart

    Cpt_Beefheart Captain

    Joined:
    Jan 4, 2016
    Messages:
    343
    Likes Received:
    382
    Nah I'm not on experimental but I did notice that bug fix line.
    -I actually went to try out experimental 5.3, wanting to focus on multiplayer but couldn't figure out where to download the dedicated server software..-which I just now did, so will get that on another machine this week unless 5.5 moves to the main branch first. -if I knew 5.5 was coming later on yesterday I wouldn't have bothered blitzing issues in this thread here!
     
    #88
    Tyrax Lightning likes this.
  9. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    Joined:
    Jun 15, 2015
    Messages:
    4,271
    Likes Received:
    5,717
    When/at which version did you start the savegame? Do you use "rollback" savegames when update or just update the server files (without touching the savegame or any other file?)
     
    #89
    Tyrax Lightning likes this.
  10. snack95

    snack95 Lieutenant

    Joined:
    Dec 21, 2016
    Messages:
    82
    Likes Received:
    9
    When/at which version did you start the savegame? > The last wipe ? > 5.0
    I do not touch the backup file, the game is automatically updated
     
    #90
    Tyrax Lightning likes this.
  11. Michael Bordeau

    Joined:
    Sep 9, 2016
    Messages:
    1
    Likes Received:
    1
    Mode: Survival
    Location: Singleplayer and Dedicated Server

    SERVER NAME: All Seeds
    SEED-ID: Various


    MODIFIED PLAYFIELDS: Yes and no, problem exists either way

    Reproducibility: Always, Dedicated server and single player as long as it is a newly created playfield
    Severity:Major, the game is unplayable for folks looking for Survival mode


    Description:

    I am unable to get any hostile creatures (Predators) to spawn in any newly generated playfield. This has been the case with the last few patches since December 2016. This is the case in single player and on my server. This is also the case with a stock playfield.yaml, and with a modified playfield.yaml and a freshly created playfield in an attempt to increase the rate of hostile spawns in single players and on my server. Other players on my server have the same issue on my server and when they are playing single player. I have been to other servers and have experienced the same issues and other servers where I did find hostile spawns. I suspect that the servers that had hostile spawns were old playfields created before December 2016.

    Just for clarification ... I am talking about hostile spawns (Spiders, Plant Monsters, Total Horrors, ect ... anything that attacks even if not provoked).
     
    #91
    Last edited: Feb 21, 2017
    Tyrax Lightning likes this.
  12. pyhfol

    pyhfol Ensign

    Joined:
    Jan 31, 2017
    Messages:
    2
    Likes Received:
    2
    hey all. No advice anyone can offer on the issues we are having? Im currently trying to get player logs.

    A suggestion was made on the Steam forums to start a new save, but thats kinda annoying for obvious reasons. Is tehre a recommended way to start a new save but migrate existing playfields?

    Cheers,
     
    #92
    Tyrax Lightning likes this.
  13. SilvRav

    SilvRav Captain

    Joined:
    Jan 13, 2017
    Messages:
    423
    Likes Received:
    345
    Similar issues I had was due to playfield issues under the respective YAML file (ie tabs, fullstop syntax errors).

    you do however say vanilla no modified playfields so not sure what it can be
     
    #93
    Tyrax Lightning likes this.
  14. Gary Parkin

    Gary Parkin Captain

    Joined:
    Aug 10, 2015
    Messages:
    461
    Likes Received:
    309
    Mode: Survival
    Location: Dedicated Server

    SERVER NAME: Parkin

    If applicable:
    MODIFIED PLAYFIELDS: No

    Reproducibility: Restored backup, all is well...
    Severity: Major

    Summary:
    Planet changed since last visit, lost ship and had to revert to earlier save.

    Description:
    On my server I reserved 2 playfields. I thought that would be enough for a 2 player game.
    We went to the moon, and I took a single ship back to Akua when my friend was not playing. When I got there, the planet had changed.
    Where we had autominers there was none, but the pins were there - see screen shots.
    The base we carved out of the mountain was gone - see screenshots.
    I figured this was just a glitch, so I landed near the base, exited the ship, ended, and restarted the game. I didn't restart the server.
    When I got back, the base was back but my ship was gone and I was marooned. Not funny at all.
    I have a batch file that backs up my game, and i had to revert to that.
    I'll make the trip again and see if the same thing happens.

    EDIT: I restored the backup, and made the same trip again. The miners were there and the base was ok. I exited the game, came back and all was well. I'll be backing up before changing playfields again.


    20170221072618_1.jpg 20170221072639_1.jpg 20170221072821_1.jpg 20170221072932_1.jpg
     
    #94
    Last edited: Feb 21, 2017
    Tyrax Lightning likes this.
  15. Tyrax Lightning

    Tyrax Lightning Rear Admiral

    Joined:
    Jan 20, 2016
    Messages:
    4,789
    Likes Received:
    3,604
    Sounds like Server Desync Issues. :(
     
    #95
  16. sillyrobot

    sillyrobot Lieutenant

    Joined:
    Aug 21, 2016
    Messages:
    61
    Likes Received:
    50
    I recreated the problem. The large constructor is still missing after exiting/entering the game.
     
    #96
    Tyrax Lightning likes this.
  17. [FoG]Mac

    [FoG]Mac Ensign

    Joined:
    Feb 22, 2017
    Messages:
    2
    Likes Received:
    2
    Mode: Survival
    Location: Singleplayer

    SEED-ID: Akua 823111

    Reproducibility: Always
    Severity: Trivial

    Summary: Honey plant in grow pots has very low view distance

    Description: When alien honey plant is in grow pots it only appears when you are very close to it

    Steps to Reproduce: As per video
     
    #97
    Tyrax Lightning likes this.
  18. [FoG]Mac

    [FoG]Mac Ensign

    Joined:
    Feb 22, 2017
    Messages:
    2
    Likes Received:
    2
    Mode: Survival
    Location: Singleplayer

    SEED-ID: Akua 823111

    Reproducibility: Always
    Severity: Minor

    Summary: Oxygen/Hydrogen generator contents disappear

    Description: With two generators, if you view the contents of one but don't collect then view the contents of the next, if you collect the contents in the second, the contents of the first will disappear.

    Steps to Reproduce: As per video
     
    #98
    Tyrax Lightning likes this.
  19. mR_kAt

    mR_kAt Captain

    Joined:
    Oct 26, 2016
    Messages:
    278
    Likes Received:
    363
    I'm still having problems with the character texture resolution option. I am still unable to set it to max still. I have a EVGA Geforce GTX 690 video card with 4 GB of RAM so I should be able to have it work in Unity. I went through e-mail support, sent my diag information, but still have received no reply after 2 months.

    In addition I have 4 graphics cards (all GTX 690) all in SLI configuration. Is there any plans to support SLI configurations in the future? It is up to the Unity engine or up to Eleon? I still never got an official response if even SLI is supported by Empyrion. Could I have a possible answer to this question (at least the SLI one) from the development team? Thanks again for all of your hard work!
     
    #99
    Tyrax Lightning likes this.
  20. Kronoss

    Kronoss Captain

    Joined:
    Oct 18, 2016
    Messages:
    399
    Likes Received:
    380
    Experimental: 5.5

    Cockpit turns white when activating SV/HV. Get out recolor it then get back in turn it back on and it turns white again. This just started happening today, and now you can't even recolor the cockpits anymore they stay white. Also some of the tools/weapons loose their texture(texture-less white color) when you exit the ship when this happens.

    Reloading the game fixes it until you either turn the power on or off.
     
    #100
    Last edited: Feb 23, 2017
    Tyrax Lightning likes this.
Thread Status:
Not open for further replies.

Share This Page