Bug Reports: Alpha 6.2.x

Discussion in 'Bugs' started by Hummel-o-War, Jun 14, 2017.

Thread Status:
Not open for further replies.
  1. Late2Gaming

    Late2Gaming Lieutenant

    Joined:
    Mar 7, 2017
    Messages:
    42
    Likes Received:
    46
    Mode: Survival
    Location: Multiplayer & Singleplayer


    Reproducibility: Always
    Severity: Code Red!

    Type: Global

    Summary: Unable to dock HV or SV to CV Size Class 30+ or game lags so bad might as well be frozen. Unplayable.

    Description: Whenever I dock any HV or SV to any CV over a size class 30+ the game will immediately lag upon moving the ship. I am able to move my character, but if I try to move the CV at all the game is unplayable. Considering I just spent 600,000+ iron as well as other vast resources this is quite disturbing.
     
    #481
  2. Carnage

    Carnage Ensign

    Joined:
    Jun 30, 2017
    Messages:
    1
    Likes Received:
    0
    Mode: Survival
    Location: Dedicated Server

    SERVER NAME: BOS
    SEED-ID: 2309115

    MODIFIED PLAYFIELDS: Yes (Pentaxid added to Skillon and all playfields set to PVE)

    Reproducibility: Unable
    Severity: Minor

    Type: CV cargo container/missing items

    Summary: Full inventory disappeared from a cargo container

    Description: I placed most of my inventory into an empty container on my CV (CV_Prefab_Tier1) to make room to loot a POI. I grabbed some loot then went to another planet to set up auto miners. I opened the cargo container that I had placed my inventory into and everything was gone.

    The POI seemed buggy, so I don't know if that was related. POI was showing as red and had weapons, but was not firing on me. (so that might be another bug?)

    Steps to Reproduce:
     
    #482
  3. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    Joined:
    Jun 15, 2015
    Messages:
    4,294
    Likes Received:
    5,791
    Can you please send in the blueprints of the vessels used? This only happens on a server? Could you try to reproduce this in a CREATIVE singleplayer game? Thanks!
     
    #483
  4. Furious Hellfire

    Joined:
    May 3, 2017
    Messages:
    358
    Likes Received:
    525
    Mode: Survival
    Location: Multiplayer

    SERVER NAME:Learn & Build
    SEED-ID: n/a

    If applicable:
    MODIFIED PLAY-FIELDS: n/a

    Reproducible: Always
    Severity: Minor
    Type: SV Door block

    Summary: An old bug this one im sure it already known.
    After relogging ,an open sv door always appears to be shut, though displays the message"press f to close door"
    when pointing at it.

    Then when f is pressed the door makes sound as if it was closing then f is required again to open the door.
    Problem is not existing with Shutters.



    Steps to Reproduce: open sv door, completely shut down empyrion and maybe allow the playfield to drop, then reload and log back in.

    Not sure if the bug applies when relogging into a playfield with players in it though it seems likely.
     
    #484
  5. zztong

    zztong Captain

    Joined:
    Apr 12, 2016
    Messages:
    446
    Likes Received:
    436
    Version: 6.3.0 1117
    Mode: Creative (I assume Survival too)
    Location: Singleplayer (I assume Multiplayer too)

    SERVER NAME: n/a
    SEED-ID: Creative Omicron Orbit

    MODIFIED PLAYFIELDS: No

    Reproducibility: Always
    Severity: Minor
    Type: O2Rooms

    Summary:

    I found a place that O2 cannot seem to reach, but should.

    Description:

    The image below shows two curved interior decking surrounded by two curved windows. The only difference appears to be the orientation of the blocks. O2 reaches one spot, but not the other.

    Steps to Reproduce:

    Build to match the screen shot.

    Screenshots, Crash Logs, any other Relevant Information or Download links:


    20170701090540_1.jpg
     
    #485
  6. Late2Gaming

    Late2Gaming Lieutenant

    Joined:
    Mar 7, 2017
    Messages:
    42
    Likes Received:
    46
    Thanks for the quick reply.

    Yes, I went and tested it just now in single player CREATIVE using just the base game and it happened there too.

    The specific blueprint I am using is: http://steamcommunity.com/sharedfiles/filedetails/?id=947613037"

    However, it seems to happen with any 30+ ship.

    The other one I tested was: http://steamcommunity.com/sharedfiles/filedetails/?id=635267384
     
    #486
  7. Late2Gaming

    Late2Gaming Lieutenant

    Joined:
    Mar 7, 2017
    Messages:
    42
    Likes Received:
    46
    #487
    Last edited: Jul 1, 2017
  8. R05340728

    R05340728 Ensign

    Joined:
    Jun 22, 2017
    Messages:
    8
    Likes Received:
    3
    Version 6.2.0 1110
    Mode: Survival
    Location: Single Player


    Reproducibility: Always
    Severity: Moderate (unless workaround is known, then Major)
    Reproducible: Yes

    Type: Global


    Game crashes around multiple light sources when Shadow Quality is set to High. Its a bit annoying because light sources shine through walls on Medium, which looks a little ridiculous.

    System Config:

    Radeon Software Version - 17.4.4
    Radeon Software Edition - Crimson ReLive
    Graphics Chipset - AMD Radeon (TM) R9 380 Series
    Memory Size - 4096 MB
    Memory Type - GDDR5
    Core Clock - 990 MHz
    Windows Version - Windows 8.1 (64 bit)
    System Memory - 32 GB
    CPU Type - Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz





     
    #488
  9. R05340728

    R05340728 Ensign

    Joined:
    Jun 22, 2017
    Messages:
    8
    Likes Received:
    3
    Version 6.2.0 1110
    Mode: Survival
    Location: Single Player


    Reproducibility: Always
    Severity: Minor
    Reproducible: Yes

    Type: Global


    Draw distance of shutter doors is shorter than other objects. This means that shutter doors are 'invisible' at certain distances. All render distances are set to Far.
     
    #489
  10. Pantera

    Pantera Rear Admiral

    Joined:
    Aug 15, 2016
    Messages:
    1,896
    Likes Received:
    1,655
    How old is your save file ?
    You may need to start a new save for the fix for this I'm afraid.
     
    #490
  11. petrkovarik99

    petrkovarik99 Ensign

    Joined:
    Jun 25, 2017
    Messages:
    12
    Likes Received:
    9
    Mode: Survival
    Location: Singleplayer

    SERVER NAME: N/A
    SEED-ID: N/A
    Game Version: 6.2.0 1110

    Reproducibility: Very often
    Severity: Low

    Type: Repair Bay Exploit

    Summary: How to get infinite resources from exploiting repair bay

    Steps to Reproduce: Place your vehicle on repair bay. Start reclaiming some part of the ship with multitool, wait until repair bay starts repairing, finish the reclamation. Repair bay will create new part. Repeat for more resources.
     
    #491
  12. xephonics

    xephonics Lieutenant

    Joined:
    Jul 18, 2016
    Messages:
    35
    Likes Received:
    36
    Mode: Creative and Survival
    Location: (Singleplayer, Dedicated Server, Peer2Peer Coop)


    SEED-ID: Everywhere

    Reproducibility: Always
    Severity: Major - it makes large ship un-repairable

    Type: building and repair


    Summary: The max block length is supposed to be 250, but it is 238 now. It makes older ships unrepairable, as you cannot lay blocks where you used to be able to.

    Description: Some time around 5.5 it started, and it is still an issue. You can no longer go 125 blocks out from the core in one direction. You cannot place blocks roughly 119 blocks. Even on ships already made, you can no longer set blocks past this limit, even if blocks exist already.

    Steps to Reproduce: try to make a ship longer 238 blocks.


    as you can see my example "ship" is 238 blocks long (the core is at the center):

    20170701124218_1.jpg


    if I try to add a block to the back, you only get a glitched block
    20170701124230_1.jpg




    And if you try to add blocks to the front, you get a red icon.
    20170701124324_1.jpg
     
    #492
  13. Really Tight Ear Muffs

    Joined:
    Mar 14, 2017
    Messages:
    4
    Likes Received:
    4
    Mode: Survival
    Location: Custom Multiplayer server host in my closet

    SERVER NAME: N/A
    SEED-ID: 19116

    If applicable:
    MODIFIED PLAYFIELDS: Yes. I made the resources on Nigues appear more often and in larger amounts. I also turned off weapon count limits. I wanted to build a mega drilling machine to bore through mountains. Those are only changes I made.

    Reproducibility: Always
    Severity: Minor

    Type: HV interface/action bar

    Summary: I can't use all the drills I've placed on my HV. Action bar doesn't show full count of all my drills.

    Description: I have placed over 30 drills onto my HV. However, pressing the left mouse button only activates 21 of them. Several do not spill or move at all. The HV has enough power and idles around the 50% power usage mark. In the HV action bar, slot number one shows the drill module icon. However, the number of drills it shows is 21. I cannot figure out how to make all my drills spin at the same time.

    Steps to Reproduce: Just put a bunch of drills on the thing and it will cap out.

    Screenshots, Crash Logs, any other Relevant Information or Download links: N/A
     
    #493
  14. Late2Gaming

    Late2Gaming Lieutenant

    Joined:
    Mar 7, 2017
    Messages:
    42
    Likes Received:
    46
    Mode: Creative and Survival
    Location: Dedicated Server


    Reproducibility: Always
    Severity: Major

    Summary: All plants aboard CV die upon switching playfields.

    Description: Upon changing playfields, all healthy plants on all CV's die. This happens simply entering and leaving an atmosphere and of course then warping anywhere. This is potentially a game-breaker if we can not feed ourselves on our space travels without having to return to a specific planet where a greenhouse is set up.
     
    #494
  15. petrkovarik99

    petrkovarik99 Ensign

    Joined:
    Jun 25, 2017
    Messages:
    12
    Likes Received:
    9
    Location: (Singleplayer)

    SERVER NAME: N/A
    SEED-ID: Dawn of Galaxy, Mayi start, 287759

    Reproducibility: Always
    Severity: Medium

    Type: Global

    Summary: Alien King Palace - mostly impossible to destroy

    Description: Most things in this place are impossible to damage, including one teleporter, walls, windows, reactor and fuel tanks. In addition, core is placed inside impenetrable walls (found with godmode). I have tried rifle, explosives and gattling guns + missile launchers on SV. Multitool reports no damage on targeted parts. The only parts I was able to damage were doors, most teleporters and internal defences.

    Steps to Reproduce:

    Screenshots, Crash Logs, any other Relevant Information or Download links:
     
    #495
  16. Ramsius

    Ramsius Ensign

    Joined:
    Dec 24, 2016
    Messages:
    2
    Likes Received:
    0
    Mode: Survival
    Location: Dedicated Server.. Nitrado

    SERVER NAME: Freedom Fighters
    SEED-ID: 2309115

    If applicable:
    MODIFIED PLAYFIELDS: No

    Reproducibility: Always, since build 1110
    Severity: Major

    Summary: small bugs, and major one involving CV's not staying where we left them



    Description:
    -so far this is always on Akua, Akua moon and Akua Orbit.
    Due to these bugs we have not made it past Akua Orbit since our server wipe/restart for Alpha 6.0
    Please find accompanying 4 screenshots to help show the problem described here in.

    this 'bug' has been plaguing us since Alpha 6.2.0.1110 update.

    However, having said that, and not sure if the other little bugs that have been steadily growing are directly related..since Alpha 6.0 (no screenshots of those.. ) I will come back to those bugs in a moment.

    In the screenshots,

    -Screenshot 1- shows three ships. Two CVs named Ranger(a Cruiser) and Support CV (SCV).. and my Interceptor (SV) all lined up on the same plane.. where I log out, sitting in my SV

    -Screenshot 2- shows when I shut the program down and then load up and log back in, you can see the SCV is skewed compaired to the other two ships.

    -Screenshot 3- shows the errors im getting in the Console Command as I log into the game. (top half).. specifically what is written in yellow. these errors seem to occur anytime i log in, on ground or in space. and all at once as u see in screenshot. something trying to load in my opinion, but isnt.

    -Screenshot 4- is the bottom half of screenshot 3 showing too the error I get After logging back in while in space. and as well the last line with "You have not specified a parent camera..." finishes saying "...unless you set the parentCamera in this script"

    What ParentCamera?

    Is the error line in Screenshot 4 related to the following issue that I describe in detail?

    *All these errors in the console show up when I log in in space... As well both My Console on my pc and my family member who plays on the server show these same errors in yellow.

    **I have not edited any scripts or tried playing with anything in the program of the game. I only use what I can from the admin rights, on the whole I like going as vanilla as possible as to how the game is meant to be played. in survival mode, I only use the admin abilities when things go awry. In creative mode I will use other console commands to help edit and design my creations.

    I have built the SCV shortly after the 6.1 update and the SV I built several updates ago, approx 4.0 and bring it out each new game we start with it updated to each new Version After it visits my ship yards in Creative mode.

    During and since the new 6.0 update we only just got to space in the last week and that is when I got the Ranger CV built. (my own rework of the prefab CV 2, I just added the back covered hanger, re-positioned some turrets, and a few other minor changes)

    the first happening of both of the CV's not staying in where we left them happened earlier last week. the Support CV(SCV) was on the Moon we had left it sitting on a base constructed to allow the CV to land flat.
    My intention and build of the Support CV is just to support planet-side POI attacks with a mobile repair pad nearby plus storage and constructor for the loot collections. It does not have warp capabilities. It does however have ventilators and two levels of sealed areas.

    When we logged back in, we found the SCV was sitting on its side and away from the Pad meant for the CV, and sitting half on our Moon Base (nick named Moon Base Alpha).

    I took the SCV to space where i spawned in the CV Cruiser (Ranger) also i spawned in a small landing base.
    All my ships + base were on the same horizontal plane using the "Auto Rotate" key.

    Logged out.

    Next day came to find Both the CV's were skewed from where i put them.. and since i logged out on one of the CV's i was booted off my ship into space.. this peculiar behaviour does not seem to affect the SV or base, so far.

    So combined with other minor bugs like drones spawning in the ground (one so far did that) a few dropping through the ground after killing them, and even a couple of AI ships in space, a Transport and a Carrier bugged out completely one self destructing for no apparent reason, the other just wigging out and sitting there and unable to go from room to room and loot it as if invisible blocks were blocking me.

    I decided that it was necessary to wipe the server and even had my own local files wiped and reinstalled..saving of course my blueprint saves.. but deleting everything else then re-installing..

    That was Thursday night (6-29-17) for the wipe. then resetting up my server and game, i have logged back in and tested things.. ie going straight to space.. spawning in the two CVs and SV..

    all the screenshots are from the new install. and as can be seen.. our problem still persists. although the CVs are not changing position as badly as before the wipe. You can see that the errors are the same in the Console.

    Oh and by the way, I always leave my CV's with the "EngineSystems" off which includes all engines and RCS's so that the ships save power. so there is also no way they would be able to move anywhere, normally.

    Steps to Reproduce: there is no game crashes as yet. But will still send along my logs from Nitrado so maybe there is something there that can be identified. As soon as i learn where and how to send them to you, If you still need them?

    Screenshots: as follows

    for any and all help thanks in advance,
    Ramsius

    Edit: noticed I had accidentally labelled this as Creative mode, i meant to label it Survival.
     

    Attached Files:

    #496
    Last edited: Jul 2, 2017
  17. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    Joined:
    Jun 15, 2015
    Messages:
    4,294
    Likes Received:
    5,791
    First: The yellow messages in the console are not bugs, but leftover debug info. Just ignore them.

    Second: Did you restart or stop the server in between (before you logged in to the server again). I assume there are no other players around?
     
    #497
  18. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    Joined:
    Jun 15, 2015
    Messages:
    4,294
    Likes Received:
    5,791
    21 is the max amount of "weapons" you can have on a vessel (working at the same time). Not a bug, but more a technical limitation.
     
    #498
  19. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    Joined:
    Jun 15, 2015
    Messages:
    4,294
    Likes Received:
    5,791
    Please report "Scenario setup issues" right here: http://empyriononline.com/threads/official-scenario-dawn-of-the-galaxy.12058/
     
    #499
  20. Repier

    Repier Commander

    Joined:
    Feb 16, 2017
    Messages:
    158
    Likes Received:
    129
    Mode: Survival
    Location: Dedicated Server

    SERVER NAME: Official public server
    SEED-ID: 2309115

    If applicable:
    MODIFIED PLAYFIELDS: No

    Reproducibility: Sometimes
    Severity: Major

    Type: Interaction between docked vessels

    Summary: When logging back in a pvp playfield, docked SV are damaging my CV and they receive damages as well.

    Description:
    I noticed several times after the server restart so after I logged back on in a pvp playfield, Aitis to be precise, that my docked sv were damaging my CV. SV were damaged as well. I had 3 SV docked and all of them suffered damages as well as CV blocks in contact.
    The last time was the worse, an explosive chain reaction occurred blowing a good part of one of the sv.


    Steps to Reproduce:
    Land your CV on a PVP playfield. Have a SV docked. Log off and then on.
    I was the only one in the playfield.

    Screenshots, Crash Logs, any other Relevant Information or Download links:
     
    #500
Thread Status:
Not open for further replies.

Share This Page