Bug Reports: Alpha Experimental 6.0 - Release Candidate 4

Discussion in 'Bugs' started by Hummel-o-War, May 29, 2017.

Thread Status:
Not open for further replies.
  1. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    Joined:
    Jun 15, 2015
    Messages:
    4,294
    Likes Received:
    5,790
    PLEASE READ FIRST!!

    1. If you haven an issue with a Base or Vessel with temperature, radiation, colliders, can-not-dock, o2 or plants not growing or anything that happens without anything else in the game world is directly affected, please ADD THE BLUEPRINT or the SAVEGAME and add an info if SP or MP! If you want to add your savegame, please upload your savegame to a cloud host (like dropbox, google,..) and add a LINK to your report

    2. If you having issues with something missing from your planet, spawned in the wrong place or anything that keeps being broken after resuming a savegame PLEASE UPLOAD the savegame to a cloud host (like dropbox, google etc) and add a LINK in your bug report

    3. If you CRASHED with a message "Continue or Quit" on a SP or MP game, PLEASE ALWAYS add the corresponding CLIENT.LOG file! You can find it in the /LOGS folder with the appropriate version name (e.g. version folder with 1022 is for version 6.x build 1022). Please do NOT copy the contents of the Client.log files to this thread!

    IF you are the server owner, please zip the corresponding LOGS folder of your server and attach it to the bug-report as well!

    4. If you CRASHED back to desktop (empyion.exe does not work anymore) do the same as in (3.).

    5. If you game FREEZES (locked up), please make a note that this is a FREEZE (not a "Crash"). Add the same files as in 3. and maybe add a dxdiag as well.

    THANKS A LOT FOR YOUR SUPPORT! :)

    -------------------------------------

    Post your bugs here using the following template:


    Mode: (Creative, Survival)
    Location: (Singleplayer, Dedicated Server, Peer2Peer Coop)

    SERVER NAME: (If the issue happened on a public server, please add the name here)
    SEED-ID: (Please always add the SEED-ID for SingleplayerSurvival games; Open the console. The Seed is noted somewhere to the "playfield loaded" dialogue)

    If applicable:
    MODIFIED PLAYFIELDS: Yes/No/DontKnow (<- YES if new planets or non-default playfields are used. Use DontKnow if you are not aware if anything has been changed)

    Reproducibility: (Always, Sometimes, Unable)
    Severity: (Trivial, Minor, Major, Crash)

    Type: (Global / O2Rooms / Temperature,Radiation / Player Armor,Boosters / Repair / Teleport,Portals / Instances / Triggers,Sensors / AIVessels / Gamestart / ... )

    Summary:

    Description:

    Steps to Reproduce:

    Screenshots, Crash Logs, any other Relevant Information or Download links:
     
    #1
    old_guy likes this.
  2. AndyofBorg

    AndyofBorg Ensign

    Joined:
    May 21, 2017
    Messages:
    20
    Likes Received:
    7
    My game is still broken! Please help!! I've been waiting several days for a new RC and still no fix. :(

    Mode: (Survival)
    Location: (Dedicated Server)

    SERVER NAME: (Private dedicated server)
    SEED-ID: (2309115)

    If applicable:
    MODIFIED PLAYFIELDS: NO

    Reproducibility: (Always)
    Severity: (Major)

    Type: ( AIVessels)

    AI Patrol Vessels very buggy. In this case, I downed one on the platform on Skilon, and it's like I'm in godmode. I jump right through it like it isn't there. It appears I'm no longer falling through the world, but the patrol vessel is a ghost. I've also seen them fall through the world and such, like go underground while flying away from me.

    Link to my savegame and dedicated.yaml: https://drive.google.com/drive/folders/0B_qaL7O9qHgyV2lCdHdMdGRGekE?usp=sharing

    Go to the PV platform with the downed ship and see for yourself...
     
    #2
  3. Pantera

    Pantera Rear Admiral

    Joined:
    Aug 15, 2016
    Messages:
    1,895
    Likes Received:
    1,655
    Have you tested on a NEW game/save file ?
     
    #3
  4. Zuleica

    Zuleica Rear Admiral

    Joined:
    Sep 24, 2016
    Messages:
    1,187
    Likes Received:
    1,356
    Mode: Survival
    Location: Singleplayer

    SERVER NAME: n/a
    SEED-ID: any

    MODIFIED PLAYFIELDS: No

    Reproducibility: Always
    Severity: Major

    Type: Sensors

    Summary: CV/BA sensors reaction to other CVs and to HVs/SVs

    Description:
    1. Sensors mounted on CVs and BAs not responding to other CVs; light beams, motion and touch plates. Are CVs and BAs intentionally invisible to sensors? And if so why in the world would they be?

    2. SVs/HVs that have triggered light beam and touch plate sensors suddenly stop triggering when docking occurs. It's utterly unreasonable to think an SV/HV suddenly becomes transparent to a light beam or massless to a touch plate sensor when they dock. It makes it extremely difficult and cumbersome to create indicators of when an SV/HV is occupying a landing spot.

    I've reported this ever since sensors were introduced in every single new patch. Are these EVER going to get fixed? When I stop reporting this as a bug it will be because I've stopped playing Empyrion. *sigh*
     
    #4
  5. jlego

    jlego Lieutenant

    Joined:
    Oct 18, 2016
    Messages:
    57
    Likes Received:
    44
    Tested these minor issues in a new save game, and still seeing them. Again, if you'd rather see any of these in a new full report, please let me know, but as they are old issues, I'll just list them here with a link to the original report:
    1. The "white flash" bug reported by nowakowsky for 6.0 part III (report post - video and repro info posted by me later in thread).
    2. Issue with constructor UI erroneously showing templates as being available for production (report post).
    3. Power usage shown on HUD at bottom right of screen for vessels is light blue instead of white.
     
    #5
    Jacoviz likes this.
  6. spacebuilder

    spacebuilder Lieutenant

    Joined:
    Nov 28, 2016
    Messages:
    20
    Likes Received:
    26
    Mode: Survival
    Location: Singleplayer

    SEED-ID: 604816

    MODIFIED PLAYFIELDS: No

    Reproducibility: Always
    Severity: Major

    Type: O2Station in HAVOC Resource Module on Ningues

    Summary:Air doesn't refill past a certain point

    Description: After filling air to 380, tried to top off with 35% in O2 tank - air depleted from tank but did not fill suit. Suit stayed at 380.
     
    #6
    Last edited: May 29, 2017
  7. Keith

    Keith Commander

    Joined:
    Dec 19, 2016
    Messages:
    123
    Likes Received:
    58
    Mode: survival
    Location: Singleplayer
    SERVER NAME:
    SEED-ID:876079
    MODIFIED PLAYFIELDS: No
    Reproducibility: Always
    Severity: major/minor /
    Type: Global
    Build: 6011 1056
    Summary: frame rate issues in space
    Description:

    Hi,

    The latest release has brought the frame rate down even more getting average of 8 fps in space.
     
    #7
  8. Green

    Green Ensign

    Joined:
    May 21, 2017
    Messages:
    18
    Likes Received:
    7
    When you go into orbit, and then use O to rotate the ship your piloting, then exit the seat... Your character has the rotation he had when he entered the seat. (So you POP to what ever your old orientation was, when you got into the seat.)

    When you enter a seat with your space suit light on.... When you exit as seat, it doesn't turn it back on. This happens dozens and dozens of times as you enter/exit vehicles on planets in the dark, and gets rather tedious.
     
    #8
  9. The Dirt Wizard

    The Dirt Wizard Commander

    Joined:
    Dec 25, 2015
    Messages:
    101
    Likes Received:
    102
    There is an issue with planting the grow plots in the new Havoc shelter. The two plots next to the oxygen ventilator cannot be planted. I think the planting area is blocked by the two "beam" blocks that are on the upper edge of the wall above.

    Its not a big deal, if this is by design to create an immediate need for the multitool. But it might be hard for new players to figure that out.

    Very nice design overall for the shelter.
     
    #9
  10. Baron

    Baron Ensign

    Joined:
    May 24, 2017
    Messages:
    3
    Likes Received:
    2
    Same Issue I posted on the candidate 3 thread still exists. Its still extremely annoying, hopefully that much is clear.

    Mode: Survival
    Location: Dedicated Server

    SERVER NAME:
    Not a public server
    SEED-ID: unknown

    If applicable:
    MODIFIED PLAYFIELDS: no

    Reproducibility: always
    Severity: Major (game killing)

    Type: The inability to salvage, repair, replace, or deconstruct our crafts at the primary areas where they take damage

    Summary: Once your vessels core is knocked out near a regenerating poi, it is UN-SALVAGEABLE. you cant repair it, replace parts in it, deconstruct it, or move it with a bigger ship.

    Description:
    This patch has killed my desire to play the experimental branch. Its has caused extreme frustration.
    Note: the core has been destroyed on the poi.
    Once your vessels core is knocked out near a poi, it is UN-SALVAGEABLE. you cant repair it, replace it, deconstruct it, or , in my case, move it with a bigger ship. short of destroying the poi, which is very time consuming for a large one, the game screws you over, and in many different ways.
    There is a number of other major issues and extreme annoyances I've encountered with this issue as well, ranging from the ui of the server software, the command console, the poi regenerating feature and the difficulties of those that I have not mentioned.
    This has been a very unpleasant experience. Along with the constant annoyances of heat, cold, air, food, enemy's, and every other thing that makes this game a fun survival game, it compounds the annoyances when dealing with a game killing (for me and the people I game with) issue. I cant stress enough how unpleasant it has been.

    I don't know what you devs are trying to achieve with this, but not letting us salvage, repair, replace, or deconstruct our crafts at the primary areas where they take damage, seems to be a very poor, very unintelligent move on your part.
    On a positive note, since this is still an experimental branch, I may actually find this game playable again.

    Steps to Reproduce: Destroy core on a regenerating poi. Get your vessels core destroyed near the poi (within anti grief radius), Now it is UN-SALVAGEABLE. you cant repair it, replace it, deconstruct it, or potentially move it with a bigger ship.

    You can "cheat" to recover it. A couple of console commands will help, IF you have access to the console commands.
    If you set the Anti-Grief range to 0 meters it makes the game playable again... kind of, IF you have access to the server config file. But that breaks pvp.
    Allow us to modify, repair, replace parts, deconstruct, or potentially move crafts with another ship near regenerating poi's and it wont be an issue.
     
    #10
    Decker_MMIV likes this.
  11. joemorin73

    joemorin73 Captain

    Joined:
    Aug 24, 2016
    Messages:
    610
    Likes Received:
    469
    Mode: survival
    Location: Multiplayer

    SERVER NAME: 24/7 EAG Experimental

    Reproducibility: Always
    Severity: Trivial
    Type: Global

    Summary: New moustache.
    Description:

    The new moustache makes my character look like an asshole. He no longer works correctly as he is constantly bragging about bands that no one has heard of, boasting about microbrews and always looking for vintage clothes.
     
    #11
    Last edited: May 30, 2017
  12. spacebuilder

    spacebuilder Lieutenant

    Joined:
    Nov 28, 2016
    Messages:
    20
    Likes Received:
    26
    Mode: Survival
    Location: Singleplayer

    SEED-ID: 604816

    MODIFIED PLAYFIELDS: No

    Reproducibility: ??
    Severity: Trivial

    Type: Drone

    Summary:Drone stuck inside POI

    Description: Pic says it all
     

    Attached Files:

    #12
  13. The Dirt Wizard

    The Dirt Wizard Commander

    Joined:
    Dec 25, 2015
    Messages:
    101
    Likes Received:
    102
    HEY!! I remember those bands, and they are going to make a comeback!
     
    #13
    joemorin73 likes this.
  14. catalina

    catalina Lieutenant

    Joined:
    Aug 28, 2016
    Messages:
    91
    Likes Received:
    73
    dud its experimental, you knew what you were getting into when you opted in
     
    #14
  15. ei8htx

    ei8htx Lieutenant

    Joined:
    Dec 18, 2016
    Messages:
    25
    Likes Received:
    35
    Mode: Survival
    Location: Singleplayer

    SEED-ID: All of them.

    If applicable:
    MODIFIED PLAYFIELDS: No

    Reproducibility: Always
    Severity: Minor

    Type: Global

    Summary: Corpses clip again

    Description: Corpses (things you've killed) clip the player. I noticed this back in RC3

    Steps to Reproduce: Go to a POI, kill a zork or zurg or whatever those bipedal aliens with guns are called, try walking on it. It will clip (block) the player, making tight passages occasionally impassable.
     
    #15
    Jacoviz likes this.
  16. DerHerrDanGer

    DerHerrDanGer Lieutenant

    Joined:
    Mar 7, 2016
    Messages:
    34
    Likes Received:
    33
    Mode: ( Survival)
    Location: (Singleplayer)

    SEED-ID: (987654321)

    Reproducibility: (Always)
    Severity: ( Major)

    Type: (Global)

    Summary: Vanishing Trees/plants

    Description: i started a new game (hard,omicron), ran to the shack, looted it, planted my o2 and constr. down at the oranges and started gathering oranges and ores of the stones. after gamebackup, exit, and reload the part of the trees i just harvested vanished. 2nd try same result.

    Steps to Reproduce: see above.

    Screenshots, Crash Logs, any other Relevant Information or Download links: https://drive.google.com/open?id=0B1yyVlhpQIx3UXhtb0NYVlBtbzg Savegame1 (#20) https://drive.google.com/open?id=0B1yyVlhpQIx3dGhLbzRGMzhZcEk savegame 2 (#21) for dualcheck. same problem.
     
    #16
  17. Baron

    Baron Ensign

    Joined:
    May 24, 2017
    Messages:
    3
    Likes Received:
    2
    Yup, That's why I posted it on the bug reports page. It's still more annoying than the bots shooting through walls (which they did fix) because that felt like a bug. This issue feels like an oversight, mistake or a poor decision.

    If there is anything constructive you can add, I will look into it.
     
    #17
    ei8htx likes this.
  18. Needleship

    Needleship Master of Custom Terrain

    Joined:
    Apr 13, 2017
    Messages:
    60
    Likes Received:
    105
    “...or just have a look if your monitor aspect ratio is now fully supported:eek:
    - Thanks for the fix!
    I just flew inside each nook and cranny of my CV with the drone. Awesome!
    ------

    But there still seems to be an issue. The fix seems to have made it worse for me. I didn't miss the drone because I never knew how cool that thing is. But now I can't really walk:


    Severity: Major
    Type: UI/ game controls
    Summary: Mouse sensitivity (turn rate) scales not uniform in different move modes - not enough turn rate for walk mode
    (Gravity vs. jetpack in zero-g or buiding drone)
    Grapics card AMD Radeon R9 M265X/ Intel HD Graphics 4600, monitor max resolution 1920 x 1080.
    Using windowed game mode, 1280 x 720, Microsoft optical mouse.


    In 'jetpack' / drone mode I can rotate more than four times fully around myself with a single maximum swipe of my wrist. More than enough. But in 'walk mode' the sensitivity is much scaled down to about 320-340° or so per wrist movement.
    My in-game mouse sensitivity is still glued to max position. I would choose even more, if I could. Is there any way to fix this, too?

    In RC4, if I walk, and every time I turn, I have to re-adjust the mouse: Take it up, move it aside in the air, place it down and then get going again. - Extremely uncomfortable to play, especially when getting shot at. Feels like moving my CV... - all the time.

    I don't really want to change the overall mouse setting of my computer, because I switch the windows when writing or letting my computer cool down*. And the setting there is more than enough to reach each corner. Also, this would pump up the jetpack turn rate again, making it all for naught.



    Again, thanks for your response! Damn, you guys are fast! :cool:

    ------
    ( * Toshiba Satellite S 70-B. Yeah, I know. Why would a sane person play games on a laptop. But work came first, and then the play.
    - Protip: "Use MSI Afterburner to turn down grapic card core clock to prevent heat shutdowns")
     
    #18
    The Dirt Wizard likes this.
  19. Force

    Force Ensign

    Joined:
    Apr 12, 2017
    Messages:
    10
    Likes Received:
    1
    Mode: Survival
    Location: Dedicated Server

    SERVER NAME: Untold Destiny
    SEED-ID: Multiplayer/NA

    If applicable:
    MODIFIED PLAYFIELDS: No

    Reproducibility: Always
    Severity: Major

    Type: Docking

    Summary: I tried to dock a SV to my BA. It now fires an error message "There is a not docked ship in your ship. Flying not possible."

    Description: I took a SV and landed it on top of my base on Omicron. It isn't listed as being docked, but I can't move it. Turning the ship off and on again does nothing. The error message "There is a not docked ship in your ship. Flying not possible" appears at the top when in my SV.

    Steps to Reproduce: Build a BA with a docking pad near some windows. Land a SV on it and the error message will fire. You will be unable to move the SV, even though it is listed as not docked.

    Here is a video of the problem happening:


    I've been able to reproduce this error by landing on a BA several times. The windows have something to do with it. The wall blocks seem to have nothing to do with the issue, but having a docking pad ringed with windows seems to cause the issue to happen 100% of the time.

    I can get the server save file if you want. Please contact me if that will help you.

    Screenshot: http://picpaste.com/20170529132457_1-VpEGe74A.jpg
     
    #19
    Last edited: May 29, 2017
  20. Force

    Force Ensign

    Joined:
    Apr 12, 2017
    Messages:
    10
    Likes Received:
    1
    Mode: Survival
    Location: Dedicated Server

    SERVER NAME: Untold Destiny
    SEED-ID: Multiplayer/NA

    If applicable:
    MODIFIED PLAYFIELDS: No

    Reproducibility: Always
    Severity: Trivial

    Type: Admin destroy command drops stuff

    Summary: Using the admin 'destroy' command on a vehicle drops all weapons and landing gear

    Steps to Reproduce: Use 'di' to get the entity id of a vehicle. Type 'destroy' then enter the id. The vehicle's mounted weapons will drop as boxes. Will also drop landing gear. Confirmed on SV.

    Very minor, just wanted to give you a heads up about it.
     
    #20
    Last edited: May 29, 2017
Thread Status:
Not open for further replies.

Share This Page