Bug Reports: Alpha Experimental 6.5.x

Discussion in 'Bugs' started by EleonGameStudios, Jul 17, 2017.

Thread Status:
Not open for further replies.
  1. Leomist

    Leomist Ensign

    Joined:
    Jul 15, 2017
    Messages:
    11
    Likes Received:
    7
    Embarrassingly old.
    I3, 8gb ram, 1gb gt320.
    Approx 7 year old.
    Whys that?
     
    #21
    Tyrax Lightning likes this.
  2. Ganytaj

    Ganytaj Ensign

    Joined:
    Jul 20, 2017
    Messages:
    1
    Likes Received:
    1
    I do not know or this is a bug. Can anyone please verify it?

    - Create a new game, set the difficulty as easy, start coop game
    - if I turn off the game and check the difficulty in the resume game window, it is set to custom and everything is different
    - when setting up a game on a medium and hard does not change that

    I apologize but this is just a google translating



    (Fixed in version 1169, thank you)
     
    #22
    Last edited: Jul 20, 2017
    Tyrax Lightning likes this.
  3. kmota123

    kmota123 Ensign

    Joined:
    Jul 20, 2017
    Messages:
    4
    Likes Received:
    4
    @Hummel-o-War @EleonGameStudios I started up a coop server for a friend and me on the experimental beta option for empyrion. It was working just fine, I had the blue screen up that said who was in server and had the save an exit option. I had forgotten to go to another save before creating the coop to get the blueprint so I exited the server with the blue screen still up in the back round because I thought I was going to be able to go to another save while the coop was still active. It wouldn't let me so I went to the blue screen and hit save and exit. The screen froze and wound't budge. After I clicked on it it gave me the option of wait for the program to respond or to close the program... I force closed the program because it wasn't wanting to work. I tried to reload reenter the server after reloading the game and it wouldn't work. So exited the game and switched back to the normal 6.4.1 update and when I went to switch back to the experimental it kept saying content locked and disk write error. So then I tried to delete the empyrion folder in steam to see if that would get it to redownload but it won't work because the empyrion dedicated folder says that I need permission to delete it. Didn't make sense on that part. So I uninstalled the game to see if that would fix it. After uninstalling and reinstalling the game, I tried to see if I could get the experimental version of empyrion to work but it wouldn't... kept on saying disk write error and content locked. When I switched back to normal the game would update just find and I can get the game to load but once ingame at the main menu I can't load any save because it says I need to shut down one server to start another. So I shut the game down and haven't touched it since today. Any ideas on how to fix this issue? The local coop seems to have messed up my game to the point to where it is unplayable and i can't update to the experimental version. And I don't have screen shots of it doing this issue because I wasn't thinking about taking any at the time I was worrying about how to fix the issue. I don't know if this info here is important or not but I also deleted the saves for the server on accident when in the regular version of empyrion. I mistook them as another set of save game files in the game.




    Edit: I can access single player now on regular version. Still can't access the experimental version
    Edit: Problem fixed.... Fixed itself.
     
    #23
    Last edited: Jul 20, 2017
    Tyrax Lightning likes this.
  4. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    Joined:
    Jun 15, 2015
    Messages:
    4,281
    Likes Received:
    5,765
    Good to hear. The "Disk write" error is something between Steam and Windows. Not much we could do here - and hard to find out what triggers this in the first place (as it resolves in 99% of all cases by itself .. what makes it hard to re-create and test).
     
    #24
    Tyrax Lightning likes this.
  5. rucky

    rucky Captain

    Joined:
    May 29, 2017
    Messages:
    744
    Likes Received:
    1,041
    Mode: (Creative, Survival) : BOTH
    Location: (Singleplayer, Dedicated Server, Peer2Peer Coop) : SinglePlayer, but I would assume ALL

    SERVER NAME: -/-
    SEED-ID: -/-

    If applicable:
    MODIFIED PLAYFIELDS: irrelevant -/-

    Reproducibility: ALWAYS
    Severity: !! CRASH !!

    Type: VESSELS, bases not tested

    Summary: CRASH when accessing the Control of not-complete vessels

    Description: ...

    Steps to Reproduce:
    - spawn some small SV / take an already build one
    - delete cockpit (or any other *important* component)
    - try to access control panel
    - ZONG ("An Error occured... blabla... EXIT and EMAIL" <--- always getting me another Problem as I don't have an Email-Prog installed!!)

    Screenshots, Crash Logs, any other Relevant Information or Download links:
    -/- (easy to reproduce)

    Devs, this is a MAJOR Bug for me, PLEASE FIX ASAP
    Sorry for the Shouting ;-) But as I have many so-called Cargo-SVs where I disassembled the Cockpit (or even more) I now can't refuel them anymore! Also while building Stuff I had to dummy put all important things on one side (RCS,Thruster,Gen,Fuel) so I can access the Control Panel without Crashing!

    THIS BUG occured in THIS LAST Version only, Yesterday it was fine.
     
    #25
    Tyrax Lightning likes this.
  6. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    Joined:
    Jun 15, 2015
    Messages:
    4,281
    Likes Received:
    5,765
    Can you reproduce this with other vessels as well?

    I just tried in Creative (delete the Cockpit of the spawned vessel and hit P) > no issue
     
    #26
    Tyrax Lightning likes this.
  7. rucky

    rucky Captain

    Joined:
    May 29, 2017
    Messages:
    744
    Likes Received:
    1,041
    3 different SVs from Library : Crash
    1 HV from Library : Crash
    1 CV from Library : Crash

    don't think it depends on the blueprint, but I can tell you which I used if you want

    Edit: I spawned them in, deleted the cockpit, hit P and BOOM
    Edit2: Also with Stock-Prefabs, just tested with SV-Prefab1
    Edit3: Is this me only???

    Just made this:
    Took SV-STARTER-BLOCK from item menu, put on ground, point to some block, hit P.... BOOM

    No-one else has this problem??

    Edit4... it gets interesting... after a restart, Starter-Block don't give error anymore...
    I'm testing more...

    VERY interesting... but I got it.

    You have to go to the DEVICES-Menu to get the error!
     
    #27
    Last edited: Jul 21, 2017
    Tyrax Lightning likes this.
  8. rucky

    rucky Captain

    Joined:
    May 29, 2017
    Messages:
    744
    Likes Received:
    1,041
    I add another post, only to get your attention, @Hummel-o-War

    Exact Steps to reproduce:

    1) Start Empyrion
    2) Make a NEW CREATIVE GAME
    3) Put down SV-STARTER-BLOCK
    4) Look at it and hit "P"
    5) Switch to DEVICES-TAB

    => BOOM

    Edit ;-) and YES, it occurs also on BASE-Starter-Block, so it occurs on ANY BLUEPRINT!
    Please Fix, Weekend is coming ;-)

    =====================================================================
    So to all out there, DON'T SWITCH TO DEVICES when accessing incomplete objects,
    and SWITCH BACK to Main at one complete object before accessing an incomplete one!!!
    =====================================================================

    Edit:
    I've seen this line in the Console after the Crash occurs:
    NullReferenceException: Object reference not set to an instance of an object
    should be the problem.
     
    #28
    Last edited: Jul 21, 2017
    Tyrax Lightning likes this.
  9. Space Beagle

    Space Beagle Captain

    Joined:
    Oct 9, 2016
    Messages:
    281
    Likes Received:
    394
    I'm getting 'error-email' crash every time when I try to auto-group devices in damaged CV (by Zir. CV & Drones) in "Shadows..." scenario.

    CV that I use is 2nd available in game for free, and is 'captured' by me next to TS in Veldis orbit (CV is called "Galactic 44").
    After first couple of crashes I disabled EAC and 'bloom' effect just in case to see is it different...
    Here you have last couple of LOGs from today, maybe you can find something useful :)

    Everything was working fine yesterday before last update. Last night in previous build '1167' I was jumped in orbit on by big Zirax CV & some drones, and my CV lost bunch of things & devices. Now after repairs every time I want to auto-group, game stops with "Continue or Quit" message. If I don't auto-group EGS works :)
     

    Attached Files:

    #29
    Tyrax Lightning likes this.
  10. rucky

    rucky Captain

    Joined:
    May 29, 2017
    Messages:
    744
    Likes Received:
    1,041
    Bug Report: Crash @incomplete structures still exists.
    Not as harsh as before, but it still crashes when in Devices Window and f.e. clicking on the yellow SOMETHING missing.
    The same red line as posted above still occurs in the console when this crash happens.
     
    #30
    Tyrax Lightning likes this.
  11. kmota123

    kmota123 Ensign

    Joined:
    Jul 20, 2017
    Messages:
    4
    Likes Received:
    4
    The only new problem I am having is reconnecting to the server. I can get the empyrion dedicated thing to show up when not in game so that isn't the issue. But when I go to connect to the server, it asks me for permission to pull the dedicated.exe file up and after I hit yes it pulls up and the game starts to connect to the server but after a few minutes the dedicated.exe file closes itself and I can't access the server making the game unplayable cause I can't shut the server off again. What can cause this?

    Edit: seems after a few hours I can play again. Found it is the dedicated.exe file for empyrion that is freezing upon clicking the save and exit to shut down the server. Don't know why it is doing that. So it is leaving me with the server on for some reason
     
    #31
    Last edited: Jul 21, 2017
    Tyrax Lightning likes this.
  12. kmota123

    kmota123 Ensign

    Joined:
    Jul 20, 2017
    Messages:
    4
    Likes Received:
    4
    This is one part of what I was talking about
     

    Attached Files:

    #32
    Tyrax Lightning likes this.
  13. rucky

    rucky Captain

    Joined:
    May 29, 2017
    Messages:
    744
    Likes Received:
    1,041

    Devs, thanx for the Fix!!
     
    #33
    Tyrax Lightning likes this.
  14. kmota123

    kmota123 Ensign

    Joined:
    Jul 20, 2017
    Messages:
    4
    Likes Received:
    4
    this is the 2nd part
     

    Attached Files:

    #34
    Tyrax Lightning likes this.
  15. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    Joined:
    Jun 15, 2015
    Messages:
    4,281
    Likes Received:
    5,765
    Control Panel Crashes should be fixed in public b1171. Closing this thread now as PUBLIC 6.5 has been released already.

    Thanks everyone for tracking down the EXP issues :)
     
    #35
    Tyrax Lightning likes this.
  16. Moonsugar

    Moonsugar Captain

    Joined:
    May 25, 2016
    Messages:
    701
    Likes Received:
    639
    Mode: any
    Location: any

    SERVER NAME:
    SEED-ID:
    any

    If applicable:
    MODIFIED PLAYFIELDS: any

    Reproducibility: Always
    Severity: Minor

    Type: Gamestart

    Summary: Settings are not remebered after restart

    Description: Since 6.5.2 rev1175 the game starts in windowed mode regardless of my choice in the previous session. When i started this rev the first time, resolution was reset to 1024x768 as well, but this was changable permanently.

    Steps to Reproduce: ?

    Screenshots, Crash Logs, any other Relevant Information or Download links:
     
    #36
    Kassonnade likes this.
  17. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    Joined:
    Jun 15, 2015
    Messages:
    4,281
    Likes Received:
    5,765
    Already on the list. thx!
     
    #37
  18. Moonsugar

    Moonsugar Captain

    Joined:
    May 25, 2016
    Messages:
    701
    Likes Received:
    639
    ... and already fixed. You guys are amazing - you fix the bugs almost faster than i can detect them...

    Well, thats another one:

    Mode: Survival
    Location:

    SERVER NAME:
    SEED-ID:
    2465681

    If applicable:
    MODIFIED PLAYFIELDS: yes, but not the current one

    Reproducibility: 50:50
    Severity: Minor

    Type: Gamestart

    Summary: drawing failure

    Description: Sometimes i can see the landscape in the windows of a SV, thats parked inside a CV. Its not always there, and mostly the issue is corrected by restaring EGS. It is only drawn if looking on untextured blocks through the windows, and it can be seen while both standing in the SV and sitting in the pilot seat.

    Steps to Reproduce: Hm. comes and goes...

    Screenshots, Crash Logs, any other Relevant Information or Download links:
    [​IMG]
     
    #38
  19. Moonsugar

    Moonsugar Captain

    Joined:
    May 25, 2016
    Messages:
    701
    Likes Received:
    639
    Ah, and even one more:

    Mode: Survival
    Location: Singleplayer
    SERVER NAME:
    SEED-ID:
    2465681

    MODIFIED PLAYFIELDS: Yes: mineral deposits twaked, meteorites eliminated, several POIs not implemented

    Reproducibility: Always
    Severity: Major

    Type: uhh... dont know...

    Summary: playfield.yaml is not evaluated correctly

    Description: i commented out all meteorites on the Akua playfield, but they still keep coming. On the screenshot you see clearly two things:
    - in the ressources window: meteorites: none, meteorites (randomly): none
    - in the map: a Co-meteorite
    I am pretty sure, the .yaml is syntactically correct. Whoever wants to check - there is it: https://www.hidrive.strato.com/lnk/LCOyxNCK

    Steps to Reproduce:

    Screenshots, Crash Logs, any other Relevant Information or Download links:[​IMG]
     
    #39
  20. Jacoviz

    Jacoviz Commander

    Joined:
    May 13, 2017
    Messages:
    129
    Likes Received:
    87
    Mode: Survival
    Location: Singleplayer

    SEED-ID: Any Seed

    MODIFIED PLAYFIELDS: No

    Reproducibility: Always
    Severity: Trivial

    Type: Global

    Summary: Weird hand model while sitting in the cockpit

    Description: If you look your character from near, you will see his hand in a weird position

    Steps to Reproduce: enter a cockpit and with the third person view look at your carachter hands

    Screenshots
    Immagine.jpg So Weird..
    Immagine 2.jpg
     
    #40
    Last edited: Jul 28, 2017
Thread Status:
Not open for further replies.

Share This Page