Bug Reports: Pre-Alpha 5.3

Discussion in 'Archive (Read Only)' started by EleonGameStudios, Feb 2, 2016.

Thread Status:
Not open for further replies.
  1. EleonGameStudios

    EleonGameStudios Developer
    Staff Member

    • Developer
    Joined:
    Oct 20, 2014
    Messages:
    1,637
    Likes Received:
    10,906
    Please post your bugs here using the following template:

    Mode: (Creative, Survival)
    Location: (Singleplayer, Dedicated Server, Peer2Peer Coop)

    Reproducibility: (Always, Sometimes, Unable)
    Severity: (Trivial, Minor, Major, Crash)

    Summary:

    Description:

    Steps to Reproduce:

    Screenshots, Crash Logs, any other Relevant Information:
     
    #1
    rafascd and Tyrax Lightning like this.
  2. WhoBerry

    WhoBerry Commander

    Joined:
    Aug 25, 2015
    Messages:
    101
    Likes Received:
    46
    Mode: Survival
    Location: Singleplayer

    Reproducibility: Always
    Severity: Trivial

    Summary: New windows not unlocked by default

    Description: Not sure if this is a bug or not but i didn't see the new windows in the constructor untill i unlocked them in the tech tree figured they would be unlocked by default?

    Steps to Reproduce: Go into constructor windows not there, go into tech tree to unlock them
     
    #2
  3. Navonil Mukherjee

    Joined:
    Aug 14, 2015
    Messages:
    897
    Likes Received:
    729
    Summary:trivial

    Description: Old icon of " generator SV/HV" in constructor/creative menu
     
    #3
  4. soup238

    soup238 Lieutenant

    Joined:
    Nov 1, 2015
    Messages:
    91
    Likes Received:
    28
    Mode: (Creative, Survival)
    Location: (Singleplayer, Dedicated Server, Peer2Peer Coop) Dedicated

    Reproducibility: (Always, Sometimes, Unable)Always
    Severity: (Trivial, Minor, Major, Crash)major

    Summary: base Turrets firing on non faction player items

    Description: turrets on my Faction base are firing on my private set ships in area, this is on PVE world turrets are set to not fire on other faction. they keep firing when turned of they keep firing when base is turned off. they only stopped when out of ammo and I can still hear them trying to reload.

    Steps to Reproduce: start game and faction turrets will fire at anything non faction

    Screenshots, Crash Logs, any other Relevant Information:
    last reset was 12/23 when 5.0 started
     
    #4
    Tyrax Lightning likes this.
  5. WhoBerry

    WhoBerry Commander

    Joined:
    Aug 25, 2015
    Messages:
    101
    Likes Received:
    46
    Mode: Survival
    Location: Singleplayer

    Reproducibility: Always
    Severity: Trivial

    Summary: Lights seem to be brighter now

    Description: See screenshots
     

    Attached Files:

    #5
  6. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    • Developer
    Joined:
    Jun 15, 2015
    Messages:
    9,309
    Likes Received:
    13,530
    1. This base has been an alien POI?
    2. Did you start a new game with 5.3 or use an old one (please add the version of your savegame)
     
    #6
    Tyrax Lightning likes this.
  7. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    • Developer
    Joined:
    Jun 15, 2015
    Messages:
    9,309
    Likes Received:
    13,530
    They unlock if you reach level 5 /nobug
     
    #7
    Tyrax Lightning likes this.
  8. soup238

    soup238 Lieutenant

    Joined:
    Nov 1, 2015
    Messages:
    91
    Likes Received:
    28
    yes it used to be a POI, but the alien turrets where all destroyed and replaced with player turrets
    its from a 5.0 start
     
    #8
    Last edited: Feb 4, 2016
    Tyrax Lightning likes this.
  9. Frederick Taer

    Frederick Taer Lieutenant

    Joined:
    Jan 20, 2016
    Messages:
    55
    Likes Received:
    37
    Mode: Creative, Survival
    Location: Singleplayer, Dedicated Server, Peer2Peer Coop

    Reproducibility: Always
    Severity: Major, Unplayable.

    Summary: Severe FPS drop with the new update.

    Description: FPS dropped from 60 to 17 in any game. That's GTX 970 and medium graphics.
    UPD: The same 17 FPS on best and fast graphics.

    So, despite of video settings, you get 17 FPS. We expect a quickfix.

    Steps to Reproduce: start or load any game.
     
    #9
    Last edited: Feb 2, 2016
  10. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    • Developer
    Joined:
    Jun 15, 2015
    Messages:
    9,309
    Likes Received:
    13,530
    Please make a screenshot of the situation where you experience the fps drop. Does this happen when starting a new game or when resuming a old game or on a crowded area?
     
    #10
    Tyrax Lightning likes this.
  11. Frederick Taer

    Frederick Taer Lieutenant

    Joined:
    Jan 20, 2016
    Messages:
    55
    Likes Received:
    37
    @Hummel-o-War, you don't understand. You get 17-20 fps no matter what video settings you set, or what situation you're at. It's not really a drop. It's a constant and stable low fps. Frame stays in 17-20, depends on scene.

    Like I said, GTX 970. Only 10 of 32 Gb of memory busy, only 10% CPU usage.

    Ok, for example, started a new single survival.

    2016-02-02_00003.jpg - best graphics - 19 FPS.
    2016-02-02_00004.jpg - good graphics - 19 FPS.
    2016-02-02_00005.jpg - fast graphics - 19 FPS.
     
    #11
  12. sixfinger

    sixfinger Ensign

    Joined:
    Sep 8, 2015
    Messages:
    9
    Likes Received:
    18
    Mode: (Game itself)
    Location: (n/a)

    Reproducibility: (Always, Sometimes)
    Severity: (Major, Crash)

    Summary:
    Schwere Ladeprobleme beim Spiel starten.
    Description:
    Mehrfaches aufhängen der exe ohne ersichtlichen Grund.
    Nach ca. 5 Minuten warten und mehrfachen Hängern erscheint (mit Glück) das Menü, beim Versuch auf einen Server zu verdingen unterbricht die Verbindung beim Laden der Daten (connection to Server lost) - Spiel beenden nur durch beenden des Prozesses
    Erneuter Versuch mit Adminrechten im Win7 Modus nach einigen Sekunden Crash to Desktop mit dem Angehängten Crashreport.
    Steps to Reproduce:

    Screenshots, Crash Logs, any other Relevant Information:
    Systemdetails etc in dem Report enthalten
     

    Attached Files:

    #12
  13. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    • Developer
    Joined:
    Jun 15, 2015
    Messages:
    9,309
    Likes Received:
    13,530
    I understand very well, but i am also owning a GTX970 and i am having no issues with framedrops so far, getting a constant 60fps. I do not even get any framedrop with my old Radeon 7950Pro on an AMD 8350 with 16gb RAM. If i may ask you that again, please hit F5 and do an new set of screenshots...even better would be to do a video.

    What's your other hardware? (Windows OS, CPU, ...)
     
    #13
    Tyrax Lightning likes this.
  14. Frederick Taer

    Frederick Taer Lieutenant

    Joined:
    Jan 20, 2016
    Messages:
    55
    Likes Received:
    37
    No problem. Windows 7 64, i7-3930K 3.2Ghz, 32Gb RAM. 2560x1440.

    2016-02-02_00006.jpg - best
    2016-02-02_00007.jpg - good
    2016-02-02_00008.jpg - fast

    Doh, it was like 60 before the update.
    Not once it was lower than 50.
     
    #14
  15. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    • Developer
    Joined:
    Jun 15, 2015
    Messages:
    9,309
    Likes Received:
    13,530
    That's really strange. Can't offer a solution for this. We are looking into the new bloom effect.
     
    #15
    Tyrax Lightning likes this.
  16. Zhama

    Zhama Ensign

    Joined:
    Jan 21, 2016
    Messages:
    1
    Likes Received:
    0
    Mode: Multiplayer Survival
    Location: Dedicated Server - War's Zone ( Omicron planet )

    Reproducibility: Always
    Severity: Crash Major

    Summary: Consistently 8 minutes after log in, I lock up then get kicked.

    Description: 3 of us tested it. All 3 of us get kicked after about 8 minutes or so. Instantly able to rejoin for a tiny rollback 30 secs or so, then 8 minutes. Server is still up, it does not seem to crash, just dumps the players.

    Some items are duplicating each roll back if it crashed while placing them in containers

    Steps to Reproduce: Every time we log into the server.

    Screenshots, Crash Logs, any other Relevant Information None at this time.
     
    #16
  17. Frederick Taer

    Frederick Taer Lieutenant

    Joined:
    Jan 20, 2016
    Messages:
    55
    Likes Received:
    37
    Awesome quick as SV hotfix solved FPS problem.
    @Hummel-o-War, can you tell us, what it was? If you can. ;)

    Although, I found new minor bug.


    Mode: Survival
    Location: Singleplayer

    Reproducibility: Always
    Severity: Trivial

    Summary: Incorrect water surface, while looking through new windows.

    Description: There is some graphic bug on water surface through new windows. It is like a line, so I think it connected with LOD somehow.

    Steps to Reproduce: look at the water through new windows.

    Screenshots, Crash Logs, any other Relevant Information:
    2016-02-02_00001.jpg - simple lanscape.
    2016-02-02_00003.jpg - lanscape through new windows, look at the crosshair.


    P.S. @Hummel-o-War, look at the FPS on screens. It's the same game! :rolleyes:
     
    #17
  18. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    • Developer
    Joined:
    Jun 15, 2015
    Messages:
    9,309
    Likes Received:
    13,530
    We've rolled out a quick technical micro-hotfix to adress some issues that could cause the framedrops. Client Version is now 5.3.0 0303

    We'll work on more performance optimizations for future updates. ;-)
     
    #18
    Tyrax Lightning likes this.
  19. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    • Developer
    Joined:
    Jun 15, 2015
    Messages:
    9,309
    Likes Received:
    13,530
    I've played on the server for the last 15 minutes. No issues. Did this happen again?
     
    #19
    Tyrax Lightning likes this.
  20. Robert Grode

    Robert Grode Ensign

    Joined:
    Feb 2, 2016
    Messages:
    2
    Likes Received:
    2
    I have about the same issue with crashing, and a bunch of crash dump files if you want them
    I have about the same issue, however is not a constant time that it crashes. I do have a bunch of crash dump reports, but i dont know where to send them

    here is the error, and the write to location is the same in every file.

    mono.dll caused an Access Violation (0xc0000005)
    in module mono.dll at 0033:5c2b1037.

    Error occurred at 2016-02-02_150652.
    C:\Program Files (x86)\Steam\SteamApps\common\Empyrion - Galactic Survival\Empyrion.exe, run by Rob.
    75% memory in use.
    8192 MB physical memory [2016 MB free].
    14491 MB paging file [2373 MB free].
    134217728 MB user address space [134207844 MB free].
    Write to location 70062000 caused an access violation.

    Oh, i thought that maybe it was something with low memory or something, so i put it on another machine with 32gig and the same crash happened.
     
    #20
    Last edited: Feb 2, 2016
    Tyrax Lightning likes this.
Thread Status:
Not open for further replies.

Share This Page