Fixed Clouds on moons render black when viewed from planet [6714]

Discussion in 'Fixed' started by ravien_ff, Sep 6, 2019.

  1. ravien_ff

    ravien_ff Rear Admiral

    Joined:
    Oct 22, 2017
    Messages:
    4,202
    Likes Received:
    8,738
    Mode: Survival
    Mode: Singleplayer

    SERVER NAME: NA
    SEED-ID: Any

    If applicable:
    MODIFIED PLAYFIELDS: No (happens with custom too)

    Reproducibility: Always
    Severity: Trivial

    Type: Moon visuals

    Summary: When viewed from a planet's surface, clouds on moons don't display correctly under certain circumstances.

    Description: When standing on a planet's surface, the clouds of the local moons will appear black and show through clouds and fog. This doesn't happen on the initial starting planet, only after teleporting using console commands (did not test entering a planet with a ship).


    Steps to Reproduce:
    Start a new game using the attached TestClouds scenario.
    Look at the moon from the planet's surface, adjusting the time using the debug menu if needed. The moon's clouds will appear fine.
    Use console command "sector Kaen" to teleport to the Kaen Orbit playfield.
    Use the debugmenu to teleport to the planet Kaen.
    Adjust the time of day if needed.
    Look at the moon in the sky, the clouds of the moon will now have black sections and will render through clouds and fog.

    Screenshots, Crash Logs, any other Relevant Information or Download links:
    Test scenario attached that spawns several default alien planets with default nascent moons.
    Screenshot:
    20190905162258_1.jpg
     

    Attached Files:

    #1
  2. ravien_ff

    ravien_ff Rear Admiral

    Joined:
    Oct 22, 2017
    Messages:
    4,202
    Likes Received:
    8,738
    Screenshot from a different planet:
    20190905030551_1.jpg
     
    #2
  3. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,526
    Likes Received:
    4,684

Share This Page