CURRENTLY not reproducible Entire Shipyard (The ships) Disappeared

Discussion in 'Currently not reproducible' started by Tempus X, Mar 1, 2021.

  1. Tempus X

    Tempus X Ensign

    Joined:
    Mar 1, 2021
    Messages:
    9
    Likes Received:
    4
    Hi!

    First post, and it's a mess. Sorry, but this is (to me) game breaking and i'm looking for some help if possible. If not fixable, the game is just getting uninstalled for good.

    BLUF: I have a creative workshop where ive been building my first CV (and a dozen iterations of it - learning is hard). It's almost complete. Almost. It isn't blueprinted. Today i did some work on it, saved, exited, and shut my lapttop down. On my next break, i loaded the game up, loaded that save, and got the "Internet error" message with a mail/quit, cont/quit, cont option. The error message basically said "Wrong header in file ents.dat" for every. single. ship. I load into the map and the POI list lists them. but i'm floating in space and it's just me. and a planet in the distance.

    What gives? How do I fix this, since the *.dat files dont open nicely in a text editor? There are several hundred hours oflost time between the shipyard and other saves (also getting boned with similar errors), and there doesn't seem to be a good solution or fix that I could (readily) find.

    For what it's worth... I'm on the newest build (Steam updated), i have a handful of subscribed vessels, i'm subscribed to project eden (not using anything from it in creative mode), and a full re-install of Empyrion is not an option, it takes a solid week+ to download it. So. Thoughts? I'm adding the save and log if that helps.
     

    Attached Files:

    #1
  2. Tempus X

    Tempus X Ensign

    Joined:
    Mar 1, 2021
    Messages:
    9
    Likes Received:
    4
    Adding the log in this post, because the forum thinks editing the original post is "spam like".
     

    Attached Files:

    #2
    Germanicus likes this.
  3. zaphodikus

    zaphodikus Captain

    Joined:
    Oct 1, 2016
    Messages:
    700
    Likes Received:
    344
    You are supposed to hit the save icon every so often, if you are paranoid, you can even rename the saves, sorry. If they are in the registry, they might well still be in play-field.
     
    #3
    Germanicus likes this.
  4. Germanicus

    Germanicus Rear Admiral

    Joined:
    Jan 22, 2018
    Messages:
    6,113
    Likes Received:
    10,149
    @Pantera @Taelyn
    Can you transfer this into the Bug Report Section? Thanks!
    (And offer Solutions of course;))
     
    #4
  5. Tempus X

    Tempus X Ensign

    Joined:
    Mar 1, 2021
    Messages:
    9
    Likes Received:
    4
    Thank you for the responses! My understanding is the save icon is really just making a backup of the game, the saving it dynamic otherwise?

    The ships are all in the..I guess registry? The poi list showed them all and places a marker in the world where they are, butt nothing shows up.

    On another note, I was able to recover a few ships by opening anew game, spawning a vessel of same type, recording that entity id#, and relaxing that particular area file with the area file from a previous save.

    Our was a huge guess n check game to figure out which of the 20-30 entity is folders was the ship I was most vested in.

    Nonetheless that was some kind of backwoods mickey mouse, duct tape style solution to get some parts of things beck.
     
    #5
    Germanicus likes this.
  6. zaphodikus

    zaphodikus Captain

    Joined:
    Oct 1, 2016
    Messages:
    700
    Likes Received:
    344
    Well, glad you did persist @Tempus X , I would not have figured this out as quickly myself either. Correct, the difference in the savegame, is that the game autosaves into the "same save" to it's not so much autosaving, as it is updating the current save. I have no idea how often it autosaves, but myself not had save issues for ages, so never dug into it.
     
    #6
  7. Tempus X

    Tempus X Ensign

    Joined:
    Mar 1, 2021
    Messages:
    9
    Likes Received:
    4
    For what it's worth, my "fix" was to follow Jascha's advice in post #6 in this thread:
    https://empyriononline.com/threads/editing-the-dat-files.7306/

    the copying the area file that is. obviously that is entity specific, and im more interested in fixing the entire "wrong header" in the ents.dat file. if someone has suggestions on what precisely is wrong with it. cause i still dont have my entire shipyard back and it's an awful big guess-n-check game with it. plus my main survival save is reporting the same error
     
    #7
    zaphodikus and Germanicus like this.
  8. Alhira_K

    Alhira_K Captain

    Joined:
    Jan 16, 2017
    Messages:
    260
    Likes Received:
    331
    #8
    Germanicus likes this.
  9. Tempus X

    Tempus X Ensign

    Joined:
    Mar 1, 2021
    Messages:
    9
    Likes Received:
    4
    That tool was not something I was aware of, so no, I had not.
    Bookmarking that for future reference however! ALl of my items are factioned, and it says it doesnt support factioned items yet so. rip :(
     
    #9
  10. Pantera

    Pantera Administrator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    7,456
    Likes Received:
    7,834
    To recover any lost structures the following should help in this situation:

    In the "Shared folder" of the save game when you go into a entities folder there should be a file called "Backup.epb" this is a backup copy of the blueprint for that particular structure. What you can do is this using your save game as an example:

    1) Navigate to the "Shared" folder in the save: Empyrion - Galactic Survival\Saves\Games\NewGame_0\Shared
    2) Next open the folder that has the entity id number of the structure you want to recover in this example "1016"
    Empyrion - Galactic Survival\Saves\Games\NewGame_0\Shared\1016
    3) Create a copy of the file called "Backup.epb"
    4) Navigate to your blueprints folder, open the folder that is named after your steam id number & create a new folder there:
    Empyrion - Galactic Survival\Saves\Blueprints\YourSteamIdAppearsHere
    5) Paste the "Backup.epb" to this folder then rename the file to anything f.ex: BackupCopy1.epb
    6) Go back & then rename the folder you have just placed the "Backup.epb" file into so it's exactly the same as the name of the blueprint (without .epb) so it will be called f.ex BackupCopy1
    7) Start the game & load into a new creative orbit & find the blueprint in the list. In this example it was named "BackupCopy1" search for that then spawn it in & rename it to anything you like
    8) Repeat the above steps for every other missing blueprint

    I cannot reproduce the initial issue "Wrong header in file" to have it analyzed & debugged to see why this happens in the first place I would need to be able to force this situation to trigger starting before the issue happens then finding a step or multiple steps to this triggering reliably.
     
    #10
    Germanicus likes this.

Share This Page