Fixed entire structures missing on entry into game [6527]

Discussion in 'Fixed (Read Only)' started by imlarry425, Apr 14, 2019.

  1. Travis9x

    Travis9x Commander

    Joined:
    Apr 22, 2019
    Messages:
    123
    Likes Received:
    39
    This is a bug that has been reported several times. Yes, it is not Zirax attacks, as your base has not actually been damaged. Chunks of the structure are simply not loading. Logging out of the server, allowing the playfield to de-spawn, then logging back in, will usually fix the problem temporarily.
     
    #41
  2. Shadex Demarr

    Shadex Demarr Lieutenant

    Joined:
    Dec 14, 2019
    Messages:
    52
    Likes Received:
    51
    Logged in a few minutes ago to find 'some' but not all of my plants dead in one of my green houses. Power and O2 were full. No radiation or heat issues, airtight. Only the spice plants died while the fruit plants lived. To add another oddity, the second green house with spice plants was perfectly fine just a few meters away. Same base. So not huge, just thought it should be documented. Thanks.
     

    Attached Files:

    #42
  3. Taelyn

    Taelyn Guest

    Happens due to the base not Always loading in one piece.
     
    #43
  4. MozoTyce

    MozoTyce Lieutenant

    Joined:
    Sep 6, 2018
    Messages:
    60
    Likes Received:
    19
    Multiplayer (hosted server)
    Default Multiplayer Un-modded

    Breathable planet, I have built into a mountain a large T4 base. The 'farm' is deep inside behind several sealed walls/doors and a forcefield (just to be safe !!).
    Several time during the playthrough i have gone to pick the garden to make ration packs and several (seemingly random) plants are dead.
    Following other players suggestions i have fitted full O2 tanks and ventilators but it still happens on an irregular basis.
    Most recently there were two of us on the server and we both raided a poi (drone base) on the other side of the planet having checked/picked the garden before leaving.
    On returning i found random death:
    [​IMG]
    [​IMG]
    Earlier today i logged in to the server and was horrified to find the power off, i immediately check the 'P' menu to be told there was no core ! I wandered towards the front of my base to see this:
    [​IMG]
    I immediately logged out and back in again to find my base was totally intact with no damage and plenty of power. Surprisingly the garden was also fine with no dead plants !

    I suspect the problem is caused by the rendering of the base. Possibly a portion is slow to be 'drawn' as a player approaches and this causes the plants to die although strangely, there is no clear line between dead plants and living plants. Mushrooms, Spice, Tomatoes, Oranges & Buds seem to die but Pumpkins & Alien Honey does not ??

    Reporting as a bug as
    a) we've seen a similar issue back in a8
    b) 'cos i'm fed up of replanting the damn garden ;)
     

    Attached Files:

    #44
  5. Relo@d

    [email protected] Lieutenant

    Joined:
    Feb 7, 2019
    Messages:
    80
    Likes Received:
    32
    Build: 12.3.1 2977 (Started fresh at A12 and have updated since)
    Mode: Survival
    Mode: Dedicated Server Multiplayer

    SERVER NAME: Our own server
    SEED-ID: 1011345

    If applicable:
    MODIFIED PLAYFIELDS: No

    Reproducibility: Sometimes
    Severity: Major

    Type: Gamestart

    Summary: Base not spawning correct at first start

    Description: Sometimes when starting first time of day or when been offline for some hours the big base is not spawned correct. Big chunks is missing and sometimes core or important stuff is gone. When restart the game client all is working as expoected.

    Steps to Reproduce: Join a dedicated server that have some play time and a big base.

    This error I have reported way back in A10 and is is so random that I cant give more information. Maby its a known error. I will return some screen shots next time. Latley its more frequent and I am not sure if its that we updated out A12 and you changed someting with Unity or other buts its very random. I feel it was less at the fresh start and more frequent now. This error happends to all four players on our server.

    I just want to report it again before Version 1 is released.
     
    #45
  6. Mirosya

    Mirosya Commander

    Joined:
    Dec 9, 2019
    Messages:
    200
    Likes Received:
    107
    Mode: Survival
    Mode: Dedicated Server or Single Player

    SERVER NAME: Private Server, 3-4 players
    SEED-ID:

    MODIFIED PLAYFIELDS: Yes (Project Eden)

    Reproducibility: Yes
    Severity: minimal but insulting

    Type: ?

    Summary: Plants dying in oxygenated rooms

    Description:
    After restarting the dedicated server, two players enter the same playfield, one of them sees the whole base, the other sees only half of the base. The visibility of the integrity of the database can be corrected by doing relogin. But at the same time, all the plants in the flower garden die :( We transplant the plants anew for the fourth time :(

    Steps to Reproduce:
    We build a base, reboot the server - we go with two, three or four players in the area of the same base, the one who does not see part of the base - will kill all the plants.
     
    #46
  7. Pantera

    Pantera Administrator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,049
    Likes Received:
    6,467
    I have tried about 30 restarts with a few players on my server & each time the structures are always appearing fine with no missing chunks.
    Can you send me the save game your server is using ? maybe it gives me some look in triggering this once & for all
     
    #47
    Germanicus, Kassonnade and Pach like this.
  8. Mirosya

    Mirosya Commander

    Joined:
    Dec 9, 2019
    Messages:
    200
    Likes Received:
    107
    #48
  9. Mirosya

    Mirosya Commander

    Joined:
    Dec 9, 2019
    Messages:
    200
    Likes Received:
    107
    I managed to repeat the situation with the disappearance of part of the database using only one client.
    I started a dedicated server - the client connected to it - everything is ok. After that I did a "quit game" and without closing the client loaded my saved game into "creative mode", exited it and loaded the saved solo game. I immediately left it and connected to the server. As a result, it turned out that in the last two screenshots - half of the base is missing and I fall into the water, since I was standing next to the flower garden.
    I think this is due to the fact that the game client does not free up memory after exiting the current game and a mess of the data of the games loaded before starts to happen in the client's memory. For example, when I exit a server game and load a saved solo game, missions from Project Eden suddenly appear in it, which should not be there. Or when, after playing in creative mode, you connect to the server, then the blueprints list shows schemes from npc ships, which should not be there.
     

    Attached Files:

    #49
    Pach, Germanicus and krazzykid2006 like this.
  10. Relo@d

    [email protected] Lieutenant

    Joined:
    Feb 7, 2019
    Messages:
    80
    Likes Received:
    32
    Debugging info: @EleonGameStudios

    Yesterday at first start after update our dedicated server to 12.3.3 I had big chunk of base missing as reported before. Today when logged on I had no errors. Maby this problem is connected to updating server thingy?

    First.jpg
     
    #50
  11. Mirosya

    Mirosya Commander

    Joined:
    Dec 9, 2019
    Messages:
    200
    Likes Received:
    107
    I checked the new patch 12.3.3 3034. The disappearance of a part of the base is just as easy to reproduce. As in the last time, I sequentially load single saves and then connect to a dedicated server - the result is in the pictures.

    P.S. The second morning I notice the following: after a long downtime without players on a dedicated server, when I start a clean client and connect to the server for the first time, the situation is exactly the same with the disappearance of half of the database. After the reconnection, everything is in place.
     

    Attached Files:

    #51
    Last edited: Aug 1, 2020
  12. Pantera

    Pantera Administrator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,049
    Likes Received:
    6,467
    @Mirosya thanks for the information I think I have something now. Will update again soon.
     
    #52
    Pach and Germanicus like this.
  13. Pantera

    Pantera Administrator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,049
    Likes Received:
    6,467
    A fix for this will be in the exp update tomorrow.
     
    #53

Share This Page