Fixed Internal Error when destroying structure and selection tool [6235]

Discussion in 'Fixed (Read Only)' started by Inappropriate, Apr 6, 2019.

  1. Inappropriate

    Inappropriate Commander

    Joined:
    Mar 17, 2017
    Messages:
    131
    Likes Received:
    163
    Mode: Creative
    Mode: Singleplayer

    MODIFIED PLAYFIELDS: No

    Reproducibility: Always
    Severity: Major


    Description: Destroying a structure with the 'Destroy' console command while it has one or more blocks selected with the selection tool causes an Internal Error loop. It doesn't seem to matter what blocks are selected. Even having empty blocks selected causes an error.

    Steps to Reproduce:
    1. Open build tools ('n' key)
    2. Turn on debug information
    3. Use the selection tool to select any block on a structure
    4. Use the 'Destroy' console command to destroy the structure that you just selected a block on


    Log file is attached. I pruned it down to just the relevant information as it was literately thousands of lines with the same error text repeated over and over.

    Also apparently I cant just attach the log directly? Weird...
     

    Attached Files:

    #1
  2. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,525
    Likes Received:
    4,684
  3. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,525
    Likes Received:
    4,684

Share This Page