CURRENTLY not reproducible Possible Oxygen depletion bug in HV

Discussion in 'Currently not reproducible' started by dracconis69, Jan 25, 2019.

  1. dracconis69

    dracconis69 Lieutenant

    Joined:
    Nov 21, 2018
    Messages:
    32
    Likes Received:
    7
    Mode: Survival
    Location: SP

    SERVER NAME: N/A
    SEED-ID: Any

    If applicable:
    MODIFIED PLAYFIELDS: No

    Reproducibility: Always
    Severity: Major

    Type: Global

    Summary: Possible Oxygen depletion bug in HV

    Description: When wearing your helmet and in the cockpit of a HV (with Oxygen switch turned off) you will continue to use your suit oxygen as intended, but the HV o2 depletes at the same time and rate as your suit o2. So instead of being able to have 2 sources of o2 when using a HV you really only have 1 source.

    Steps to Reproduce: There are no steps as it is right out of the box.

    Screenshots, Crash Logs, any other Relevant Information or Download links:
     
    #1
  2. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    • Developer
    Joined:
    Jun 15, 2015
    Messages:
    9,304
    Likes Received:
    13,514
    Tried this on the Moon with an oxygenized HV and could not reproduce.
    With Helmet ON and O2 OFF, only the suit was dropping.
    With Helmet ON or OFF and O2 ON, only the HV tanks were dropping

    (maybe fixed, but, if you can, maybe retry in the current EXP version or wait until it is released the coming week and re-try if the same is still happening and re-report :)
     
    #2
  3. dracconis69

    dracconis69 Lieutenant

    Joined:
    Nov 21, 2018
    Messages:
    32
    Likes Received:
    7
    I just tested that process with the 9.2.1 2173 upgraded to 9.3.0 2209 and sitting in the cockpit of an HV with the O2 turned off and helmet on the O2 in the HV is going down without the O2 in my suit changing at all this time with the new update. However I will assume that with the HV O2 turned off I should not be using the HV O2 at all.
     
    #3
  4. Zaflis

    Zaflis Commander

    Joined:
    Sep 15, 2017
    Messages:
    322
    Likes Received:
    182
    I can replicate the issue but only with a closed cockpit block. Both SV and HV. I might even assume this is working as it's meant to work, but not sure. Traditionally the oxygen toggle has meant only ventilators.

    However it's not using suit oxygen, only the vehicle's tank. This when helmet is on and ship oxygen is off.
     
    #4
  5. dracconis69

    dracconis69 Lieutenant

    Joined:
    Nov 21, 2018
    Messages:
    32
    Likes Received:
    7
    This HV does not have a ventilator but even then with the O2 turned off and your helmet on you should not be using the HV o2. You should only be using the Suit O2.
     
    #5
  6. Zaflis

    Zaflis Commander

    Joined:
    Sep 15, 2017
    Messages:
    322
    Likes Received:
    182
    What kind of cockpit is it, open or closed?
     
    #6
  7. dracconis69

    dracconis69 Lieutenant

    Joined:
    Nov 21, 2018
    Messages:
    32
    Likes Received:
    7
    Closed of course, otherwise I wouldn't have started this post.
     
    #7
  8. dracconis69

    dracconis69 Lieutenant

    Joined:
    Nov 21, 2018
    Messages:
    32
    Likes Received:
    7
    Well starting a brand new 9.4 world, spawning in a new HV, adding 1k O2 to the tanks, turning the HV O2 off, going to the moon, getting in the HV and HV O2 depletes yet again despite being turned off.
     
    #8

Share This Page