Fixed [REOPEN] No Update on Rocks and Plants for other players. [6752]

Discussion in 'Fixed' started by Philipp, Sep 13, 2019.

  1. Philipp

    Philipp Captain

    Joined:
    Aug 30, 2016
    Messages:
    566
    Likes Received:
    269
    REOPEN, same as here: https://empyriononline.com/threads/...nts-for-other-players-6722.74005/#post-349365

    10.5 (Build 2642) Experimental


    Mode: Survival

    Mode: Local Coop

    MODIFIED PLAYFIELDS: Just some adjustments on how many ores, what kind of ores and stuff like that.

    Reproducibility: Always
    Severity: Major

    Type: Network

    Summary: [REOPEN] No Update on Rocks and Plants for other players.

    Description:
    The Ores are fine now!

    But we still have Problems with Rocks and Plants.
    If both Players are near each other, its no Problem, but when far away from each other (600m +) the other Player won't get updates.

    Example:
    Player_1 destroys some Rocks and collects some Plants while Player_2 is far away (600m +).
    Player_2 returns to that position and sees the Rocks and the Plants are unharvested (but he can't harvest them or destroy the rocks).

    ROCKS:


    As you can see in this screenshot: Darby liebt Razor_2019-09-12_22-16-49.png
    That's a rock my girlfriend already destroyed but it still gets shown for me. It only happens when both players are far away from each other!


    PLANTS:

    The problem with the plants however gets worser with this update, and we have 2 Problems:
    1. Problem)
    As you can see in this screenshot: Darby liebt Razor_2019-09-13_00-06-01.png
    This is a screenshot my girlfriend made, you can see that she could collect the plants but they appear as they aren't regrown yet.
    This already happend in build 2625, but only with single plants. Now when it happens, it happens to about 5- 7 plants that are all near each other.

    2. Problem)

    Also: Plants that were collected by a Player while the other one is far away appear to be uncollected.
    ###

    As in build 2625 only rejoining the server fixes the issue


    It is the same bug as here: https://empyriononline.com/threads/...ks-trees-plants-for-other-players-6696.69775/
    and
    https://empyriononline.com/threads/...nts-for-other-players-6722.74005/#post-349365

    Steps to Reproduce:
    See Description

    Screenshots, Crash Logs, any other Relevant Information or Download links:
     
    #1
  2. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,530
    Likes Received:
    4,685
  3. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,530
    Likes Received:
    4,685
    Just to ask about this does it happen immediately for you after picking some plants or after a certain amount of time ?
     
    #3
    Kassonnade likes this.
  4. Philipp

    Philipp Captain

    Joined:
    Aug 30, 2016
    Messages:
    566
    Likes Received:
    269
    It happens when the plants should been regrown, not immediatly.
     
    #4
  5. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,530
    Likes Received:
    4,685
    Ok can you update to B2643 you show you are on B2642 ?

    When trying this issue you mention in local co-op & on a dedicated server the rock is gone when I return & the same with the plants so far.
    How much time roughly is the player who is far away away for so this triggers ?
     
    #5
    Kassonnade likes this.
  6. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,530
    Likes Received:
    4,685
    Actually hold of on that for now there appears to be a exception causing co-op mode to be broken when another player tries to join let me check.

    Can you attach the Client log from your self & your girlfriend ?
    & also the Dedicated_log & Client_AsPf from the logs folder of the host of the co-op game zip them up & attach them here for me to check please thanks.
     
    #6
    Kassonnade likes this.
  7. Philipp

    Philipp Captain

    Joined:
    Aug 30, 2016
    Messages:
    566
    Likes Received:
    269
    This happens very fast. Lets say Player_1 goes 1 km away, collects some plants and destroys some rocks, and then, maybe some seconds later, Player_2 starts moving to that location, then all the rocks are still there for Player_2, same for the plants.

    But it also happens if Player_2 stays, lets say one hour away, and then returns. Same problem.

    I added two files now: Logs.zip is from me (I'm hosting the local coop server) and LogsGirlfriend.zip are the ones from my Girlfriend.
    We just played with local coop in Build 2642, if you need Logfiles from the "normal" dedicated server, that would be in build 2625, but if you need them i could upload them, too.
     

    Attached Files:

    #7
  8. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,530
    Likes Received:
    4,685
    Ok thanks I'll look at them.
    Does the issues you reported in the OP also happen on the standalone dedicated server using the same save game or a different one ?
     
    #8
    Kassonnade likes this.
  9. Philipp

    Philipp Captain

    Joined:
    Aug 30, 2016
    Messages:
    566
    Likes Received:
    269
    yes we got the same issues, no matter if we play on the dedicated server or local Coop.
     
    #9
  10. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,530
    Likes Received:
    4,685
    Ok I have found a way to trigger most of this which will be looked at asap.

    I cannot reproduce this so far can you supply the save game with your character left standing infront of the plant in the screenshot of another that goes like this ?

     
    #10
    Kassonnade likes this.
  11. Philipp

    Philipp Captain

    Joined:
    Aug 30, 2016
    Messages:
    566
    Likes Received:
    269
    great!

    If the exact same thing happens again we send you the save with the character standing right next to it.
    This morning we didn't found that problem again, but maybe this one helps you, too:
    forum (1).png forum (2).png

    This is me and my girlfriend standing next to the plant, it seems regrown but couldn't get harvested by none of us.

    Here's the link for the save with us standing next to the plant:
    https://drive.google.com/open?id=1XTM940FnuiXjplz5yCk9z6WveAyaDeZG
     
    #11
  12. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,530
    Likes Received:
    4,685
    There will be fixes to address these in the next exp release:

    ====

    But this I need to be able to find these trigger before it happens I have separated it it here to this thread for the now https://empyriononline.com/threads/plant-growing-issue.75675/

     
    #12
    Kassonnade and Philipp like this.
  13. Philipp

    Philipp Captain

    Joined:
    Aug 30, 2016
    Messages:
    566
    Likes Received:
    269
    allright, next time we have this problem, i will put my character next to that plant and send you the savegame on the new thread.
     
    #13
  14. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,530
    Likes Received:
    4,685

Share This Page