CURRENTLY not reproducible Some textures loading in low resolution

Discussion in 'Currently not reproducible' started by Nazo, Jun 20, 2022.

  1. Nazo

    Nazo Ensign

    Joined:
    Jan 28, 2022
    Messages:
    10
    Likes Received:
    3
    For more information see here Bug Report Template

    Build: 1.8.1 3843
    Mode: Survival (solo)
    Mode:

    If applicable:
    MODIFIED PLAYFIELDS: None (most mods are not even updated for 1.8.x yet.)

    Reproducibility: A bit random
    Severity: Minor, but very annoying

    Type: Graphics

    Summary: Rarely I see a texture for something randomly load as a low resolution stand-in instead of the full textures.

    Description: Sometimes as I'm playing the game, rarely I'll run into something where the texture does not load fully and I get a low resolution stand-in instead. It seems to be a bit random. For example, in my previous game I saw it on a guard's armor, but this time I see it on a large construction device. I've tried to google around and so far the closest answer I've found in on systems with 8GiB of RAM the game used to use low resolution textures automatically -- but they were talking about a much much earlier version. Also, I have 16GiB of RAM on this system and my videocard has 8GiB of dedicated VRAM. When I checked the task manager (presuming I can trust its numbers) it showed 6.9GiB of the videocard's 8GiB actually in use and only just over 8GiB of system RAM in use (with Empyrion itself actually using surprisingly little system RAM -- I forgot to take note of exactly how much the game itself was using, but I think it was something like 3.5-4GiB or so maybe.) I exited to the main menu so it unloaded a bunch of stuff then reloaded my save and VRAM usage dropped to about 4GiB and Empyrion dropped to 2.5GiB of system RAM usage, but the large constructor I was looking at is still a low res texture even though, no matter how you look at it, RAM is definitely not an issue right now.

    I didn't have this problem in the past, however, a bunch of things have changed at once. I upgraded my PC components, including the GPU -- my previous GPU being a 1060 with 6GiB of VRAM. I did not have the chance to play the game very much since the upgrade before the 1.8 version came out, so I can't actually verify if it may be something specific to this setup. Interestingly, if I look at the task manager it shows "shared GPU memory" listing a total of 16GiB available to the videocard (not sure if this is a PCIe 4.0 thing or maybe even a side effect of Resizable BAR -- though that's particularly doubtful -- both of which my components support and have enabled,) though it was still only using 6.9GiB at the highest at that point earlier and even less after reloading, so I don't really think that explains it. I don't know if task manager may be failing to list things like perhaps whatever shaders and the like use. Another thing of note is that the game is now running from a faster SSD than the previous system had (the previous system had a relatively "slow" older generation SATA SSD, now I'm using a NVME PCIe 4x drive that also has faster raw reads/writes on its own.)

    I do have ReShade, however, I keep my actual shader usage to a fair minimum with the only heavy shader being SMAA (I like its SMAA just a little bit better than the game's antialiasing, so I turned off the game's own AA and use that instead.) The rest are just extremely small brightness, color, and sharpness tweaks so use barely any resources at all. I had these same shaders before on the previous hardware with the 1060 and its 6GiB of VRAM, though I have increased the graphics settings a bit since the 3060 Ti is obviously significantly more powerful. Oh, and it's probably not related, but my CPU usage is incredibly low in this game, so that's definitely not a problem (but then the previous CPU seemed to handle the game pretty ok too anyway.)

    Most of the game's graphics settings are on high or maximum, though I've turned off DoF and Bloom because I hate them and of course the antialiasing for the aforementioned reason. It runs at a constant 60 FPS (I have a 60Hz monitor, so I set 60 as the maximum FPS) so it's not dropping anything to make up frames.

    I don't know if this could just be a 1.8.x bug or something in my setup that has changed from before unfortunately. I can't really setup the old hardware to test on

    Steps to Reproduce:
    1) Unknown. I believe it may specifically require playing for a few hours until RAM usage goes up to something of a peak.

    Screenshots, Crash Logs, any other Relevant Information or Download links:
    Example screenshot (the large constructor):
    Low Res:
    [​IMG]
    Normal after full game reload:
    [​IMG]
     
    #1
  2. Rodan

    Rodan Ensign

    Joined:
    Jun 23, 2022
    Messages:
    3
    Likes Received:
    4
    For what it's worth, I was having this exact same issue. I was caught off-guard by how garbage the constructors were looking, and I found this post.

    I was following the 'how to report a bug' steps and after deleting the cache folder (<steam game dir>\Saves\Cache) and verifying integrity of files, when I reloaded my save the textures appear to be back normally. I will keep an eye on it also and if it re-appears I will update with details if I can reproduce.

    Hope this is helpful, cheers.
     
    #2
  3. Rodan

    Rodan Ensign

    Joined:
    Jun 23, 2022
    Messages:
    3
    Likes Received:
    4
    To update, this seems to happen after playing for about an hour or so, especially if I've travelled to another area and back (i.e. using a teleporter then returning). The biggest offenders seem to be constructors, solar panels, and various storage boxes, but not regular blocks... so - functional blocks? Not certain if there is a distinct pattern.
     
    #3
    Germanicus and Pach like this.
  4. Rodan

    Rodan Ensign

    Joined:
    Jun 23, 2022
    Messages:
    3
    Likes Received:
    4
    Another update, after messing with various video settings, I found that turning texture streaming off seems to help.
     
    #4
    Germanicus and Pach like this.

Share This Page