More Info needed Splash Damage through Cockpit?

Discussion in 'Bugs' started by CatmanDoes, May 29, 2019.

  1. CatmanDoes

    CatmanDoes Lieutenant

    Joined:
    Nov 16, 2017
    Messages:
    37
    Likes Received:
    44
    Not sure if this is new as I've returned to the game and missed a couple of major releases but I was in my SV with armored cockpit taking out a POI, I took a few hits but took out the turrets. My shield was depleted.

    Next thing I see is 3 rockets from ground troops soar up and straight into my ship cockpit. Boom, I die body jumps up above the ship and starts to fall where I can see my cockpit is still intact - is this intentional? Used to be your cockpit got blown out sending you falling to the ground. Surely the blast shouldn't be making it into the cockpit?

    They appear to do 9,000 damage to ships, am I reading this right? :

    Code:
    { Item Id: 2623, Name: ZiraxRocketWeapon
      StackSize: 1
      Category: Weapons/Items
      Mass: 12, type: float, display: false, formatter: Kilogram
      {
        AllowRemote: false
        ROF: 1.5, type: float, display: true, formatter: ROF
        Range: 100, display: false
        IgnoreAtmo: true
        AmmoCapacity: 5, display: true
        AmmoType: rocketDrone, display: true
        BulletSpread: 0.5, display: true
        ReloadDelay: 3.9, display: true
      }
    }
    Code:
    { Item Id: 2601, Name: rocketDrone
      StackSize: 25
      Category: Weapons/Items
      {
        Damage: 150, display: true
        BlastRadius: 3, display: true
        BlastDamage: 500, display: true
        Speed: 90
        Range: 360
        Ballistic: false
        DamageMultiplier_1: 0.5, data: head|body
        DamageMultiplier_2: 3, data: metal
        DamageMultiplier_3: 25, data: metalhard|concrete|woodblock|hull <--- 150 * 25 = 3750
        DamageMultiplier_4: 60, data: hullarmored|hullcombat  <--- 150 * 60 = 9000
        DamageMultiplier_5: 0, data: stone|dirt
        DamageMultiplier_6: 0.1, data: shield
        BlastDamageMultiplier_1: 0.5, data: head|body  <--- 500 * 0.5 = 250
        BlastDamageMultiplier_2: 0.05, data: stone|dirt
        BlastDamageMultiplier_3: 0, data: shield
      }
    }
     
    #1
    elmo likes this.
  2. Pach

    Pach Captain

    Joined:
    Dec 16, 2017
    Messages:
    490
    Likes Received:
    584
    I had something like this happen just the other day on a server (not one I'm admin of).

    I spawned in a brand new SV, and was out exploring with it.

    Found a POI, it had 4 of the green beam turrets. Normally, I can take a few hits from those.

    All of a sudden I get my character's death cry, I'm out of the cockpit, and "you are dead from an explosion".

    It was a *brand new* ship, and I was shot out of it? May have an old cockpit style on it, though, but I've used it many times before against the same kind of turrets (same POI, I think, too), without this issue:

    https://steamcommunity.com/sharedfiles/filedetails/?id=1415453043
     
    #2
    CatmanDoes and elmo like this.
  3. elmo

    elmo Captain

    Joined:
    Sep 26, 2017
    Messages:
    183
    Likes Received:
    362

    @jlego and myself had this same problem last week. We were in HV tanks with shields but turrets from POIs killed both of us several times. Hardly any damage to outside of vehicles. We have never been killed that often in this game in one playthrough. @jlego put in 2 bug reports and we were told it was fixed. Looks like you might be having a similar problem
     
    #3
    CatmanDoes likes this.
  4. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    4,487
    Likes Received:
    3,782
    @CatmanDoes Can you retry this in A10 experimental ?
    How old is the config file is it updated or a you using the default Config_Example.ecf with no edits made to it ?

    There was a fix just done in A10 for possibly the same thing.
     
    #4
  5. Pach

    Pach Captain

    Joined:
    Dec 16, 2017
    Messages:
    490
    Likes Received:
    584
    @Pantera :

    Mine happened just yesterday, after the patch.
     
    #5
    Germanicus likes this.
  6. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    4,487
    Likes Received:
    3,782
    Experimental right ? just to ask as this is in the public section.

    If exp please create a thread with a use case where it can be reproduced so it can be examined.
     
    #6
    Germanicus likes this.
  7. jlego

    jlego Captain

    Joined:
    Oct 18, 2016
    Messages:
    263
    Likes Received:
    349
    Hmm... like @elmo said, I had tested that issue and I thought it had been fixed in A10 Part III because I couldn't reproduce it. It's one of those issues that's inconsistently reproduced, though.

    Am I correct in thinking that your vessel hull was intact (as well as your cockpit), and you're definitely in build 2482?
     
    #7
  8. Pach

    Pach Captain

    Joined:
    Dec 16, 2017
    Messages:
    490
    Likes Received:
    584
    Whoops. Sorry. Yes, mine was EXP.

    Don't know if I can reproduce it, since it was on a server (I don't own), but I'll see what I can do.
     
    #8
  9. jlego

    jlego Captain

    Joined:
    Oct 18, 2016
    Messages:
    263
    Likes Received:
    349
    Tried again to reproduce this in build 2482, with HVs and SVs and under the same conditions I mentioned in my Part II bug report, but it doesn't appear that I am able to now (and that's the second time I've tried in Part III).
     
    #9
  10. CatmanDoes

    CatmanDoes Lieutenant

    Joined:
    Nov 16, 2017
    Messages:
    37
    Likes Received:
    44
    Thanks will try it on A10.2
     
    #10
  11. Gaz

    Gaz Lieutenant

    Joined:
    Dec 6, 2016
    Messages:
    60
    Likes Received:
    61
    yep has happened to me , one shot from a defence turret and boom . Now i tunnel under them and take out there exposed cores. I try to get around most bugs.
     
    #11
  12. Vidar

    Vidar Ensign

    Joined:
    May 29, 2018
    Messages:
    2
    Likes Received:
    1
    I've had this happen multiple times in different vehicles, both HV and SV on an experimental 10 server. Both vehicles are enclosed with cockpit seating instead of a standalone self-contained cockpit block. Full shield and no damage to the vehiclesand I'll get killed while the shield is still up and the ship is still around me.

    "You died in an explosion."

    This has happened twice in an HV resulting in me losing both vehicles and twice in an SV, which I also lost both vehicles. By the time I respawn and get back with something that can take out the defenses, my vehicles are scrapped because the turrets just continued to pound away at them until the core was gone.
     
    #12

Share This Page