Fixed Statistics doesn't update Roll/Pitch/Yaw 'real time' in Creative. [6963]

Discussion in 'Fixed (Read Only)' started by Jollificator 2, Nov 19, 2019.

  1. Jollificator 2

    Joined:
    Jul 15, 2019
    Messages:
    19
    Likes Received:
    18
    Mode: (Creative)
    Mode: (Singleplayer)

    When building a CV/HV/SV, values for roll/pitch/yaw in Statistics don't get updated until you enter the cockpit. Values for forward, side and backward thrust however do get updated in real time.
     
    #1
    Fenra369, runlykhel and krazzykid2006 like this.
  2. -=Ice=-

    -=Ice=- Lieutenant

    Joined:
    Jul 5, 2017
    Messages:
    36
    Likes Received:
    19
    +1 to this report
     
    #2
  3. Fenra369

    Fenra369 Commander

    Joined:
    Apr 5, 2016
    Messages:
    240
    Likes Received:
    120
    Can confirm it even updates +-1 unit of torque when a ship is powered on or off. No clear indication of why this happens.
     
    #3
  4. dazkaz

    dazkaz Lieutenant

    Joined:
    Apr 25, 2019
    Messages:
    52
    Likes Received:
    30
    Mode: Survival
    Mode: Dedicated Server


    SERVER NAME: Eleon Studios - Official Server/Vanilla/Default MP Scenario
    SEED-ID: Don't know

    If applicable:
    MODIFIED PLAYFIELDS: DontKnow
    Reproducibility: Always
    Severity: Major

    Type: Game Mechanic

    Summary: Since the latest Hotfix turning in a CV has become painfully slow.

    Description: The latest hotfix seems to have broken the turning speed of CVs.
    Possibly SVs as well, according to another player.
    This problem will go away after a short time, but comes back again after turning the thrusters off and back on again.


    Steps to Reproduce: Turn on the thrusters and turn the vehicle. Keep flying and the turn rate will eventually return back to what it was before the hotfix. This length of time appears to be random. Turn off the thrusters and the problem will return when you turn them back on again.
     

    Attached Files:

    #4
    Barra74 and Ski like this.
  5. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,654
    Likes Received:
    4,788
    Are you able to show this issue before, during & resolving with some video ?
    Currently going of your report I cannot reproduce this behavior.
     
    #5
  6. dazkaz

    dazkaz Lieutenant

    Joined:
    Apr 25, 2019
    Messages:
    52
    Likes Received:
    30
    I have the problem almost every time on my SV at the moment.
    I updated the CV with a T2 RCS and have not had the problem from it since.
    What I have discovered is opening the stats window and closing it again clears the bug.
    Also of interest, might be that the stats, on opening it, for the turn rate, are much reduced.
    After reopening it however, they are back to normal.
     

    Attached Files:

    #6
  7. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,654
    Likes Received:
    4,788
    Thanks I'll merge it with a thread that is already for what you mention then post when a fix is ready to be tried out.
     
    #7
    dazkaz likes this.
  8. dazkaz

    dazkaz Lieutenant

    Joined:
    Apr 25, 2019
    Messages:
    52
    Likes Received:
    30
    Here is the video to reproduce it.
     
    #8
    Jollificator 2 likes this.
  9. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,654
    Likes Received:
    4,788

Share This Page