CURRENTLY not reproducible Time skip to day drains all power without doing anything

Discussion in 'Currently not reproducible' started by Ambaire, Oct 28, 2019.

  1. Ambaire

    Ambaire Captain

    Joined:
    Nov 23, 2015
    Messages:
    708
    Likes Received:
    528
    My solar battery had 40% left and my constructor had 6 15mm ammo to craft. I used the bed, and the capacitor instantly fully drained without the constructor crafting anything. Had I waited, it would probably have had about 35% left...
     
    #1
  2. Ambaire

    Ambaire Captain

    Joined:
    Nov 23, 2015
    Messages:
    708
    Likes Received:
    528
    As an addendum, I used the bed when the constructor had ~5s remaining on a single hover booster, with 2 full solar capacitors. Checked it after sleep and they had somehow gone down to 80%...

    Eleon, your algorithm for night skip power usage is borked.
     
    #2
  3. Foofaspoon

    Foofaspoon Ensign

    Joined:
    Oct 28, 2019
    Messages:
    5
    Likes Received:
    5
    I've noticed this a number of times, is very annoying! Also drains fuel as well at times
     
    #3
  4. Ambaire

    Ambaire Captain

    Joined:
    Nov 23, 2015
    Messages:
    708
    Likes Received:
    528
    Just happened again on the 10.6 branch. I had a bunch of SV parts queued, 40 minutes of battery power left. Time skipped to day at ~9 hours left and all power was drained and the constructor hadn't done anything more.

    edit: sorry, that was uncalled for. I'll try to make a save at night so you have an easy way to replicate this bug.
     
    #4
    Last edited: Nov 9, 2019
  5. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,530
    Likes Received:
    4,686
    Hi I have been trying this out but each time I go to sleep the constructors are completing what I have queued up for them with no issue so far.

    If you load into your save game does it happen every time you sleep ? (if you could supply the save game also that may help trigger this)

    What 'Constructor crafting setting' is the save game using ?
     
    #5
    Ambaire likes this.
  6. Ambaire

    Ambaire Captain

    Joined:
    Nov 23, 2015
    Messages:
    708
    Likes Received:
    528
    Give me a couple hours and I'll try to upload a save. I should've done that in the first place...

    edit: I use the 'slow' constructor speed
     
    #6
  7. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,530
    Likes Received:
    4,686
    Thanks no problem I'll try it some more using different settings & see if I can trigger anything.
     
    #7
    Ambaire likes this.
  8. Ambaire

    Ambaire Captain

    Joined:
    Nov 23, 2015
    Messages:
    708
    Likes Received:
    528
    It seems that bug only triggers about 10% of the time, so I'm not sure how to reliably reproduce it... I managed to get it to trigger once, but the next 5 tries worked as expected.

    I did manage to get the bug to trigger again, so I made a backup of that game and attached it as Night Test Backup-191109-1354.zip, if that's helpful.

    I've discovered a second bug in the process (steps 6-9)... heh. These are the steps I followed to get the second bug to trigger, but it seems like a fool's errand to try to get the first one reliably :(

    Second bug is: if I copy a game, load the copy, do something to drain the solar battery then exit, delete the copy, copy it again and load the second copy, the solar battery will still be drained.
    1. Extract the Night Test Backup zip to your Alpha 10.6.0 2697 save directory
    2. Launch Empyrion, Resume Game, click 'Copy' on the Night Test Backup game, then resume the copy.
    3. Open the control panel first and note that 27% battery charge remains
    4. Open the large constructor GUI, click the device tab and shift-click the SV generator 10 times to queue up 60 of them (just for testing purposes.
    5. Sleep at the bed behind you
    6. The base should be out of power and the constructor has not crafted a single item
    7. (This step is only for 'reproducing' the nothing crafted and out of power bug, skip otherwise) If the constructor managed to craft some items, exit to menu, delete the copy, exit the game (since the second bug I discovered), and resume from Step 2.
    8. Exit to the menu, delete the NTB copy, copy it again and resume the second copy
    9. Check the control panel and note how the base, despite being a fresh copy, still has a drained solar battery, at the beginning of night.

    Not sure what's up with that...

    edit: I forgot to restart my game before loading my main save and the battery was still drained despite a completely different save name. sigh
     

    Attached Files:

    #8
    Last edited: Nov 9, 2019
  9. jk5325

    jk5325 Ensign

    Joined:
    Nov 11, 2015
    Messages:
    22
    Likes Received:
    13
    Hey im not sure if this is related to the above issues, but the power outputs dont make any sense.
    Base idles at 262PU, Large constructor takes it to 762PU while solar current ouput is 1.33kPU (Avg 1.07kPU).
    So i should be able to run the constructor without powerloss, but no if constructor is on power drain quickly.
    Additionally i cant add extra panels, game seems to think i have 21 panels. Base has 7 small panels.
     
    #9
  10. Ambaire

    Ambaire Captain

    Joined:
    Nov 23, 2015
    Messages:
    708
    Likes Received:
    528
    You should post this in a separate thread. It is not related.
     
    #10
  11. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,530
    Likes Received:
    4,686
    @Ambaire to update I haven't been able to reproduce this issue as soon as I have something I'll update here.
     
    #11
    Ambaire likes this.
  12. Foofaspoon

    Foofaspoon Ensign

    Joined:
    Oct 28, 2019
    Messages:
    5
    Likes Received:
    5
    I've found it very intermittent as well... If I get it again I'll upload a save. I've not encountered it again by dint of never sleeping while my constructor is running!
     
    #12

Share This Page