UPDATE v1.6.3

Discussion in 'Patch Notes' started by Pantera, Oct 12, 2021.

  1. Pantera

    Pantera Administrator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    7,840
    Likes Received:
    8,766
    Hi Galactic Survivalists!

    Here is the changelog for v1.6.3 with some fixes we have been working on. Have fun and please report bugs and problems as usual - thanks a lot!

    As always please note:
    Report bugs and issues for the public release right over here:
    https://empyriononline.com/forums/bugs.24/

    2021-10-12 v1.6.3 (Build 3512)

    Changes:
    - Improved darkness with post processing inside structures

    Fixes:
    - Removing O2/Fuel from tanks via logistics deletes them
    - Vessels sporadically moving after playfield changes when setup on a repair block
    - Set of decorations not working correctly with deco knock down system -> fixed | DeadTree02aPrefab, AkuaBush1Prefab, OmicronPlantPrefab, OmicronWaterleafPrefab
    - Fixed an exploit

    EAH:
    - https://eah.empyrion-homeworld.net/download/patch-notes-emp-admin-helper-full
     
    #1
  2. Myrmidon

    Myrmidon Rear Admiral

    Joined:
    Mar 26, 2016
    Messages:
    2,332
    Likes Received:
    2,838
    Again thank you for the update and the fixes. :thumpUp:


    Upd. : I would like to add that after playing the game on 720 I think it is very gorgeous as if I am on 1080, apart some blurriness here and there, which means the game is more GPU friendly. I hope those who need low resolution to play on older or weaker GPUs than mine (GTX1070) will find to more pleasurable now.
     
    #2
    Last edited: Oct 12, 2021
    Tyrax Lightning and Germanicus like this.
  3. Bob [OG]

    Bob [OG] Commander

    Joined:
    Oct 31, 2018
    Messages:
    102
    Likes Received:
    146

    how about an option to disable?
     
    #3
    Tyrax Lightning likes this.
  4. Taelyn

    Taelyn Administrator
    Staff Member Community Manager

    • Developer
    • Administrator
    Joined:
    Oct 4, 2021
    Messages:
    89
    Likes Received:
    200
    Might be added in the future yes

    This was the first step
     
    #4
  5. Kassonnade

    Kassonnade Rear Admiral

    Joined:
    May 13, 2017
    Messages:
    5,524
    Likes Received:
    7,616
    Looks like the "advance Core / player" is broken.

    I updated the game, started a new one on medium difficulty, spawned a base with the SBP console command enabled and added some devices. Got a warning for exceeding CPU limit, so I changed the normal "green" core for an advance Core, but warnings continued and the generator eventually overloaded.

    I quit the game, re-loaded my save, replaced broken devices, removed and re-added the advance Core and warnings for exceeding CPU still come in, and eventually generator blows up again...

    Something I missed in some patch notes regarding the Advance Core ?

    NewGame_2021-10-12_10-50-02.png

    Edit : the spawned base is a simple armored concrete block 40 x 40 x 10, with just a few devices added a few blocks below the top.

    .
     
    #5
  6. krazzykid2006

    krazzykid2006 Rear Admiral

    Joined:
    Feb 28, 2017
    Messages:
    2,356
    Likes Received:
    3,029
    @Kassonnade how long are you waiting before powering it on AFTER adding the core?
    The default game has a delay when adding or removing CPU tiers before it recalculates (I believe it's 60 or 120 seconds, but might be more).

    Since adding that core technically is a change to the CPU tier (disabled tier) it might also have that delay before it recalculates.

    Just an idea, might be wrong. I'm not at home to test for you right now.
     
    #6
    Tyrax Lightning likes this.
  7. Kassonnade

    Kassonnade Rear Admiral

    Joined:
    May 13, 2017
    Messages:
    5,524
    Likes Received:
    7,616
    This has no link to the problem.

    I started yet another game, medium difficulty, this time making sure the CPU was OFF, as it is by default anyways (I almost never play with CPU on).

    I spawned the same base (40x40x10 armored concrete slab) and right after spawning it I removed the normal "green" player core and placed the advance Core on top level. I then added all devices that I placed in my previous game, put fuel + pentaxid + O2 in tanks and turn the base switch "on". I immediately got an alert for exceeding CPU limit.

    Then I just put a T4 CPU extender on the base, and alerts stopped immediately. Advance Core is just there for decoration, it is obviously without effect. But that's not even the point : CPU is disabled from the game start anyways...

    NewGame_0_2021-10-12_14-32-22.png

    I saved and exited the game and Steam completely, and restarted. Loaded my savegame, base runs fine. I removed the T4 CPU extender, and maybe 10 seconds later I got the alert for exceeding CPU limit, with the Advance Core still there.

    NewGame_0_2021-10-12_14-45-23.png
     
    #7
    Last edited: Oct 12, 2021
  8. Scoob

    Scoob Rear Admiral

    Joined:
    Sep 22, 2016
    Messages:
    4,507
    Likes Received:
    7,780
    Hi,

    An old bug appears to have resurfaced.

    I was constructing a new CV in Survival while using the "YZ" Symmetry plane. I placed a Medium Thruster in the centre of the plane - with the green grid intersecting it of course - and TWO Thrusters were consumed from my Connected Toolbar. Needless to say only one Thruster was actually placed, so I lost one.

    I did the same thing again at the other end of the CV and, once again, two Thrusters were consumed for one actually placed.

    Can anyone else confirm this?
     
    #8
  9. Tevishtszaat

    Tevishtszaat Ensign

    Joined:
    Sep 24, 2021
    Messages:
    9
    Likes Received:
    1
    Advanced cores work fine. They just have lower CPU than the rest. You are exceeding cpu limits with your equipment.
     
    #9
  10. Kassonnade

    Kassonnade Rear Admiral

    Joined:
    May 13, 2017
    Messages:
    5,524
    Likes Received:
    7,616
    What are you talking about ?

    NewGame_0_2021-11-24_19-48-35.png
     
    #10
    krazzykid2006 likes this.

Share This Page