New Possible leak with NPC spawning/AI

Discussion in 'Bugs' started by Inappropriate, Aug 3, 2021.

  1. Inappropriate

    Inappropriate Captain

    Joined:
    Mar 17, 2017
    Messages:
    352
    Likes Received:
    404
    Build: 1.5.3 3390
    Mode: Survival
    Mode: Single player

    MODIFIED PLAYFIELDS: Yes. Reforged Eden but can also be seen in the base game. RE seems to have higher spawn rates of foot patrols so its easier to notice but that could just be my luck.

    Reproducibility: Always
    Severity: Critical

    Type: NPC AI, Spawning, Performance

    Summary: Possible leak with NPC spawning/AI

    Description: When visiting areas that are heavily populated by NPCs such as planetary faction territory I have noticed a heavy hit to my frame rate. The strange part is that the low frame rate persists even after leaving the area and the POIs and NPCs supposedly unload. The frame lose isn't that bad while standing still (2-5) but is VERY extreme (up to 30!!!) while moving. Moving into another populated area causes further loss of frame rate. Only by leaving the playfield can I get my frame rate back up to a stable 60. I can then return to the playfield and the frame rate will remain stable until I visit a populated area again.

    Steps to Reproduce:
    1. Start a new survival game.
    2. Turn on the frame monitor.
    3. Turn on God Mode or spawn an SV so you can move around the playfield quickly.
    4. Travel to the middle of Polaris territory and note the frame rate.
    5. Travel far into the wilderness so that everything in Polaris territory unloads while monitoring the frame rate.
    6. Travel to the middle of Talon territory and note the frame rate.
    7. Travel far into the wilderness so that everything in Talon territory unloads while monitoring the frame rate.
    8. STOP MOVING and note the frame rate.
    9. TAP any directional key to move 1 or 2 meters while monitoring the frame rate. Moving up/down has no effect; it hast to directional movement.

    My specs
    CPU:i9 9820x (no OC)
    MB: ASUS WS X299 SAGE
    RAM: 32 GB DDR4
    GPU: EVGA GTX 1070
    PSU: 850 watts
    OS: Windows 10 Pro

    Drivers are all up to date. Games frame rate is capped at 60.

    === Edit ===
    I decided to open up the task manager while moving around in game and discoverd something interesting: while standing still my GUP utilization hovers between 70 and 76 percent during my current play session but if I move GUP utilization falls to between 48 and 54 percent. Yes, that's right, GUP utilization goes DOWN while walking around instead of standing still.
     
    #1
    Last edited: Aug 13, 2021
  2. Inappropriate

    Inappropriate Captain

    Joined:
    Mar 17, 2017
    Messages:
    352
    Likes Received:
    404
    Just to update this: Im still having this issue in v1.5.5
     
    #2
  3. Inappropriate

    Inappropriate Captain

    Joined:
    Mar 17, 2017
    Messages:
    352
    Likes Received:
    404
    Second update: Changing the playfield no longer seems to clear out whatever is causing this. I now have to quit to the main menu and reload to get my frame rate back up.

    Also edited the OP to change bug severity to 'Critical' as it makes the game basically unplayable without inducing a major headache from eyestrain caused by unstable frame rate.

    Game version: 1.5.5 3444
     
    #3
    Serj2121 and -AKEVA-BANSHEE- like this.
  4. Serj2121

    Serj2121 Ensign

    Joined:
    Aug 7, 2021
    Messages:
    6
    Likes Received:
    1
    My frame rate also drops when approaching a POI. v1.5.5 3444 (((
    Very sad!
     
    #4
  5. Inappropriate

    Inappropriate Captain

    Joined:
    Mar 17, 2017
    Messages:
    352
    Likes Received:
    404
    Update 3:

    Still seeing this in 1.5.6.
    Also this seems to happen in space too. Once any POI (BA or CV) with lots of NPC activity loads in frame rate never recovers even after the area is supposedly unloaded.
     
    #5
    -AKEVA-BANSHEE- likes this.
  6. -AKEVA-BANSHEE-

    -AKEVA-BANSHEE- Commander

    Joined:
    Oct 9, 2020
    Messages:
    115
    Likes Received:
    83
    I have seen this happen and corroborate this as well. Happens in base game POI testing saves I do.
     
    #6

Share This Page