Recessed hitscan weapons may not fire while moving

Discussion in 'Bugs' started by Garaman, Aug 4, 2022.

  1. Garaman

    Garaman Captain

    Joined:
    Aug 23, 2020
    Messages:
    298
    Likes Received:
    390
    Build: 1.8.6 3862
    Mode: Survival / Creative
    Mode: Single Player / Multiplayer

    Reproducibility: Always
    Severity: Minor / Major

    Type: Weapon collision detection

    Summary: SV and CV hitscan weapons will sometimes fail to fire if they are placed in a recessed location on your build

    Description:
    If you have a hitscan fixed weapon (ex: SV railguns or drills, CV pulse laser or drills) placed on your ship and you try to fire them while moving the weapons will sometimes fail to fire. On SVs this has been manifesting as undermounted weapons failing to fire while attacking POIs. On a recent SV build of mine with the drills recessed back into the body they went from operating normally in 1.8.4 to only sporadically working in 1.8.6.

    I suspect that it has something to do with the hitscan calc lagging behind the ship's actual collision mesh? There are times when you turn your ship and you will see a prompt saying "This seat is currently occupied", and in the video below you can see my crosshair turn red indicating the weapon (or my view?) is intersecting something even though there is clearly nothing in front of me. My guess is the hitscan weapons suddenly think they are firing at a point on the ship instead of straight ahead, and therefore attempting to fire through the ship itself?

    Steps to Reproduce:
    The example below is contrived, but since the issue does not reproduce regularly I wanted to try to get something that manifests all the time. I did notice that the yaw rate when using the keyboard keys is tied to your framerate (...which...yeah...) so I'm demoing this with my frames locked to 60 fps in the settings menu.
    1. Load the attached epb in a creative game in orbit. The CV features a pulse laser cannon on the left and a drill laser on the right, and both are recessed 4 blocks inside the hull of the ship.
    2. Set your frame rate limit to 60 FPS in the options menu.
    3. Load the ship with some Ls.Charge II CV and fuel
    4. Sit in the pilot seat and hold the left key to rotate the ship to the left.
    5. While rotating, start firing the pulse laser. You will see the ammo count drop, but no shots will fire.
    6. Stop rotating and the weapon will start firing.
    7. Switch to the drill laser and repeat this process turning right instead. The drill will fail to fire if you try to initiate it while turning.
    The video below shows this occurring on my machine. At the end of the video I just move the ship left and right a bit so you can see the crosshair turn red like it's seeing something, even though there's nothing in front of me.

    Screenshots:
     

    Attached Files:

    #1
    Last edited: Aug 4, 2022
    TwitchyJ and ravien_ff like this.
  2. ravien_ff

    ravien_ff Rear Admiral

    Joined:
    Oct 22, 2017
    Messages:
    7,781
    Likes Received:
    13,568
    Thank you for taking the time to report this.
     
    #2
  3. A.F.T

    A.F.T Grand Admiral

    Joined:
    Nov 7, 2015
    Messages:
    20
    Likes Received:
    9
    It is not a bug It is bad design. When you put weapons deep into the ship the safety feature is triggered. To avoid the damage your own ship. When you moving - weapon have focus on crosshair and line of fire can be cross the ship hull. Try to do the same with "free camera" (ALT). All will bbe working.
     
    #3
  4. ravien_ff

    ravien_ff Rear Admiral

    Joined:
    Oct 22, 2017
    Messages:
    7,781
    Likes Received:
    13,568
    It's definitely a bug because it consumes ammo but does not fire.
     
    #4
  5. Garaman

    Garaman Captain

    Joined:
    Aug 23, 2020
    Messages:
    298
    Likes Received:
    390
    Plus these are hitscan weapons. The laser drills especially don't even converge, they should always fire straight ahead regardless of view direction or mode. I have an SV with an undermounted rail for placing fixed weapons, and any hitscan weapons that have a clear line-of-sight out the front and sides but are a few blocks under the long nose have a chance to not fire if I'm moving in the wrong direction.

    But I think this is a larger issue than even this. For example, I've noticed sometimes while flying that my O2 indicator starts flickering, like the game can't decide if I'm actually in my cockpit or not. I mentioned that sometimes when turning you'll get an interaction prompt for your own cockpit or pilot seat. This was an annoyance before 1.7, seemed to get worse in 1.7/1.8, and as of 1.8.5/.6 I have cases where hovering perfectly still in an SV with recessed laser drills they will completely not fire at all whereas they worked perfectly before.
     
    #5
    jmaasing likes this.

Share This Page