PLZ Retest and Re-Report Tutorial on taking over a base has incorrect information.

Discussion in 'Archive (Read Only)' started by Shadowpheonix, Jun 9, 2022.

  1. Shadowpheonix

    Shadowpheonix Ensign

    Joined:
    May 19, 2022
    Messages:
    10
    Likes Received:
    4
    Build: 1.8 3823
    Mode: Survival
    Mode: Singleplayer

    SERVER NAME:
    SEED-ID:281277

    If applicable:
    MODIFIED PLAYFIELDS: No

    Reproducibility: Always
    Severity: Trivial
    Type: Tutorial

    Summary: Tutorial on taking over a base has incorrect information.

    Description:
    The tutorial on how to take over a base states that you receive 100% of the resources when salvaging a block with any tool. This is incorrect - you get a very small quantity of the resources when using the survival tool, and a larger quantity (but not all) when using a multi-tool.


    Steps to Reproduce:
    1) Start a new singleplayer survival game with any seed, using Akua as the starting planet.
    2) Navigate to the "Supply Bunker" POI.
    3) Navigate through the POI to the location of the core.
    4) Read the tutorial messages about why you would want to take over a base that pops up.

    Screenshots, Crash Logs, any other Relevant Information or Download links:
     
    #1
    Last edited: Jun 9, 2022
  2. Pach

    Pach Rear Admiral

    Joined:
    Dec 16, 2017
    Messages:
    1,020
    Likes Received:
    1,206
    Happen to have the exact text handy?

    Because if you take over a base (which is what you said the tutorial is for), that's actually correct: if you take over the base (place your own core), and use a MT on the blocks, you get the whole block (100% of the resources).

    So it depends how it's worded in what you saw?
     
    #2
    stanley bourdon and Germanicus like this.
  3. Hummel-o-War

    Hummel-o-War Administrator Staff Member Community Manager

    • Developer
    Joined:
    Jun 15, 2015
    Messages:
    7,657
    Likes Received:
    11,918
    Good point, yes. Never the less, please let me know in case there is false info ( plz make a screenshot when the info pops up plz. Easier to find for me then :D )



    The main text info (given in the Dialogue)
     
    #3
    Pach likes this.
  4. TwitchyJ

    TwitchyJ Commander

    Joined:
    Mar 4, 2022
    Messages:
    110
    Likes Received:
    84
    No need for a screenshot. If that is the actual text then we already found the issue.
    Salvaging does not return more components if you own the structure. You do not get all components back when you salvage.

    The two options on the multitools are salvage and retrieve blocks.
    Salvaging does not ever return 100% of components with any tool, regardless of ownership of the structure.

    Survival tool and T1 multitool is 33% components.
    Multitool T2 is 66.7% components.
    HV and CV tool turret is 80% components.

    So your quoted text above is wrong. You do not get more efficient salvaging at all based on ownership, nor do you get back all components ever (unless you pick the whole block up and put it in a deconstructor).
    Plus, the type of tool you are using ABSOLUTELY matters.
    Everything about the text is incorrect.
     
    #4
  5. Shadowpheonix

    Shadowpheonix Ensign

    Joined:
    May 19, 2022
    Messages:
    10
    Likes Received:
    4
    OK. I just started a new game, went to the Supply Bunker and got the dialog again. Here is the portion I was referencing...
    [​IMG]



    This tutorial dialog is incorrect, as you do NOT get back 100% of the resources for a block. As proof, here are my results when I tried salvaging Small Generators in the Supply Bunker after placing my own core in it:

    For reference, if you check in the Tech Tree or in a Constructor you will see that crafting a Small Generator costs...
    Motor: 1
    Electronics: 4
    Carbon Substrate: 7.

    This is what I got when I salvaged one of the 2 Small Generators that already existed in the Supply Bunker using a Survival Tool...
    [​IMG]


    I then cleared my inventory and salvaged the other pre-existing Small Generator using a Multi-Tool...
    [​IMG]


    I then cleared my inventory again, placed a new Small Generator, then turned around and salvaged it using a Multi-Tool (T2)... (This one is humorous to me as it returned more motors than is needed to craft the block, but still didn't return enough resources to actually craft the block).
    [​IMG]





    As you can see, I received a different amount of resources depending on which tool was used - and more importantly, NONE of them matched the resource cost to actually craft the blocks I was salvaging (I in fact had to salvage 3 blocks before I would have obtained enough resources to craft 1). This is a a very far cry from the tutorials statement of "you get back ALL components when you dismantle building blocks and devices - and you don't lose anything".


    I did not take any further screenshots, but I did place down & salvage several more Small Generators, and discovered that the resource quantities I got back was actually random, with the average quantities appearing to be better with the better tools.

    I then salvaged a bunch of other device blocks and building blocks, to confirm the issue is not specific to Small Generators. The ONLY blocks that I ever got 100% back were the ones that only needed a single unit of a single resource (IE: Cement Block always returned 1 Concrete, which is all it takes to craft one).

    To confirm the issue was not specific to the Supply Bunker, I then crafted a completely new base from scratch (following the base building tutorial), then added & salvaged a few different devices and blocks from it. The results were the same - I did NOT get back all of the resources for the stuff I was salvaging.

    In summary, the tutorial says you get back ALL of the resources for any block salvaged with any tool on a base you own, but in truth the vast majority of blocks do not return 100% of the resources back, regardless of which hand-held tool is used (I did not test any ship mounted salvage tools, so cannot say if they return 100% or not).


    On a side note, I tested salvaging blocks from an owned base in the official release build, and that also fails to return 100% of the resources. This is the primary reason I believe it is the tutorial dialog that is incorrect and not the salvage quantities being returned in the Experimental version.
     
    #5
    Last edited: Jun 12, 2022
    stanley bourdon and Pach like this.
  6. Hummel-o-War

    Hummel-o-War Administrator Staff Member Community Manager

    • Developer
    Joined:
    Jun 15, 2015
    Messages:
    7,657
    Likes Received:
    11,918
    Ok, thanks for the detailed analysis! Will check!
     
    #6
    Pach likes this.

Share This Page