Fixed BUG: Fish Out of Water

Discussion in 'Fixed (Read Only)' started by IndigoWyrd, Dec 19, 2019.

  1. IndigoWyrd

    IndigoWyrd Rear Admiral

    Joined:
    Jun 19, 2018
    Messages:
    1,177
    Likes Received:
    1,369
    Clearly we have no fish, but we have vessels, and currently (00:45 EST) the Official US Public Server is suffering from a horrendous bug. Whenever a vessel is powered off, the cockpit exited, then re-entered and powered back on, the vessel begins to behave like a fish out of water. It will spin, roll, pitch, bounce off of, into, and through the ground, as if the ship were made of rubber. It is virtually impossible to control a ship affected by this. The smaller and lighter the vessel, the more noticeable the issue is.

    I currently have an SV and an HV stuck to my base on my starter planet, as they have been rendered virtually unusable by this. Leaving them alone on the ground causes them to continue to flip, bounce and skip along. At least when docked they stay in place.

    I have also observed this same behavior in SP Survival, though it appears to have "worked itself out."
    Logging out and back in may remedy this for a short time, however any use of roll or auto-roll will trigger this spastic behavior again.

    It is more severe at higher speeds. Speeds less than 40% seem to greatly reduce this issue.

    I'll reference this thread in the Official US Server forum as well.
     
    #1
  2. Ephoie

    Ephoie Captain

    Joined:
    Jan 27, 2018
    Messages:
    492
    Likes Received:
    488
    Not that I can do anything, but I would love to see a video of this behaviour.... mainly for my entertainment.... But i can empathize with how frustrating this might be. I do hope it is resolved for you.
     
    #2
    dichebach likes this.
  3. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    • Developer
    Joined:
    Jun 15, 2015
    Messages:
    10,332
    Likes Received:
    15,667
    I am afraid i am not able to reproduce this behavior. Do you think you can add a video, including the steps to trigger this behavior?
     
    #3
    Ephoie likes this.
  4. jlego

    jlego Captain

    Joined:
    Oct 18, 2016
    Messages:
    297
    Likes Received:
    424
    I also experienced this issue yesterday with two different HVs on separate occasions in a coop game with @elmo. When it occurred, leaving the cockpit would cause the affected vessels to flail wildly several metres in the air or falling underground and teleporting back up, until I could manage to reenter the cockpit. Docking to a base forces it to stay still. Turning off hover engines and thrusters (as I normally do when stopping at my destination) seems to lead to more extreme effects than if they are left on.

    The issue occurred suddenly after some time in the game session, and went away after a server restart. Unfortunately, I was too busy trying to regain control of the vessels at the time and it didn't occur to me that I should fire up OBS to record it (in hindsight, I should have).
     
    #4
  5. fa_q2

    fa_q2 Lieutenant

    Joined:
    Oct 30, 2019
    Messages:
    34
    Likes Received:
    19
    I can say that there were at least 5 of us that experienced the exact same issue last night as well. It seems to be a really common problem. Had it happen to one of my CVs.
     
    #5
    Ephoie, dichebach and Travis9x like this.
  6. IndigoWyrd

    IndigoWyrd Rear Admiral

    Joined:
    Jun 19, 2018
    Messages:
    1,177
    Likes Received:
    1,369
    I will try this evening, if the issue is still occurring. It wasn't doing it on Tuesday.

    Confirmed - fa_q2 was there when this was happening. Hiya fa_!
     
    #6
    dichebach likes this.
  7. Spogie

    Spogie Ensign

    Joined:
    Dec 19, 2019
    Messages:
    2
    Likes Received:
    4
    You can add two more with CVs to the list. I think more than half of the US server left because everyone was complaining in chat about it, and no one could not find an admin or moderator to try any fixes.

    Two CVs, been using for days without issue, No changes to the ships were made.
    Occurs in space and on planet, changing playfields didnt make a difference.
    Trigger by mouse movement or touching terrain.
    Powering off in space seems to stop it, but powering off and hitting terrain does not stop it from 'flopping' around.
    Issue is bound to the ship, not the player; when a player can exit the ship, they can fly other ships without issue.
    Players not having the issue, will flip flop in the broken ship.
    If a player remotely access the ship 'stuck' and powers on/off the ship, it will flip flop without a pilot on the terrain.

    Attempted: Relogging in, rebuilding files via steam, removing RCS, removing generators, even after the schedule server reboot, no fix.
     
    #7
    SacredGlade and Travis9x like this.
  8. Travis9x

    Travis9x Commander

    Joined:
    Apr 22, 2019
    Messages:
    110
    Likes Received:
    28
    I can confirm this is also happening in our private server. All of our vessels are virtually unusable, although it would seem to be nearly opposite of the OP. For us, if there is a pilot in the cockpit, the vessels behave normally. But as soon as the cockpit is empty, the vessel bounces around and falls through the terrain. Does not seem to matter whether the power is off or on.
    This also seems to be triggering the collision damage bug, because if we're able to regain control of the vessel, we find that after all the craziness, many blocks have sustained inexplicable damage.
     
    #8
    dichebach likes this.
  9. Hummel-o-War

    Hummel-o-War Administrator
    Staff Member Community Manager

    • Developer
    Joined:
    Jun 15, 2015
    Messages:
    10,332
    Likes Received:
    15,667
    Plz retry with the current update and re-report the issue (Afaik there were a few fixes added on the matter of "uncontrollable vessels"). Please be very specific, what you report, as "uncontrollable" can be anyhting from freaking out Torque values to "terrain colliders" collision. Thats why i was askink for videos (also in the other threads) ;)
     
    #9
    dichebach and jlego like this.
  10. jlego

    jlego Captain

    Joined:
    Oct 18, 2016
    Messages:
    297
    Likes Received:
    424
    FWIW, we were playing on 2758 today, and the issue didn't occur, but I can't say whether that's due to the fixes or the issue just not being triggered. We'll keep an eye on it and report if it happens again (hopefully with video).
     
    #10
    Ephoie, dichebach and Hummel-o-War like this.
  11. Spogie

    Spogie Ensign

    Joined:
    Dec 19, 2019
    Messages:
    2
    Likes Received:
    4
    ver: 11.5.3 (2758)
    Attached video of fresh login
    I didn't notice the massive roll deg/s and Toeque details before. as I general had my engines offline.
     
    #11
    Wellingtoon and dichebach like this.
  12. Pantera

    Pantera Moderator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    5,874
    Likes Received:
    5,049
    The issue/behavior with that vessel you show in your video is something we are looking at currently.
    When a fix is ready a update will be posted here.
     
    #12
  13. dichebach

    dichebach Captain

    Joined:
    Oct 26, 2016
    Messages:
    642
    Likes Received:
    631
    I have a save file (or five) where it is happening. PM me if you guys need me to email it to you.
     
    #13
  14. dichebach

    dichebach Captain

    Joined:
    Oct 26, 2016
    Messages:
    642
    Likes Received:
    631
    THAT is exactly what I've been experiencing and have save files if they are needed.
     
    #14
    Wellingtoon likes this.
  15. IndigoWyrd

    IndigoWyrd Rear Admiral

    Joined:
    Jun 19, 2018
    Messages:
    1,177
    Likes Received:
    1,369
    Yep, that's it exactly. Tried to capture video, but I believe EAC interferes with my screen recorder, as I am unable to start a recording.
    Good to know this is already being looked into!
     
    #15
    Wellingtoon likes this.
  16. fa_q2

    fa_q2 Lieutenant

    Joined:
    Oct 30, 2019
    Messages:
    34
    Likes Received:
    19
    No idea about everyone else but so far this has happened to every one of my ships that has either docked or had something docked to it.

    Ships I have not docked anything to have not bugged out. Everything else has unfortunately.
     
    #16
  17. Kaz

    Kaz Ensign

    Joined:
    Dec 14, 2019
    Messages:
    22
    Likes Received:
    11
    I was playing on a server tonight and everything was fine for a few hours, i did a few pois unloaded the loot and then spent a bit of time warping around looking for a good orbit for a space station, then a server reboot happened and everything was fine for around 20 mins. I had decided to put an ore/wood container controller on my cv so i switched the normal controller for that one hopped in the pilot seat to move it and then this happened:
    I was piloting it when it started, i tried turning it off and on and reloging but thats all i could do however because i cant get to the core and i dont have the resources to remake it. So far its only happened on the server.
     
    #17
    Ephoie likes this.
  18. Ephoie

    Ephoie Captain

    Joined:
    Jan 27, 2018
    Messages:
    492
    Likes Received:
    488
    That looks like a collider issue. This is probably from adjustments to the collider mechanics. Hopefully its resolved with the latest update in exp branch.
     
    #18
    Kaz likes this.
  19. Roughneck270

    Roughneck270 Ensign

    Joined:
    Feb 2, 2019
    Messages:
    28
    Likes Received:
    15
    Still happening. I also have video if needed.
     
    #19
  20. OutlawCecil

    OutlawCecil Lieutenant

    Joined:
    Jul 3, 2016
    Messages:
    41
    Likes Received:
    27
    Our faction is experiencing the exact same. We've done testing and have found it's directly related to volume of stuff in container controllers. We have some cargo lifter SVs and CVs and most of them will do this if we fill them (?over 30%ish?) with stuff. Using F4 while flopping around, I can dump stuff and immediately the flopping stops.

    Side note: If this is happening to you and you aren't stuck in a wall or in the ground, switch camera mode using alt and only move using W, A, S, D. Don't use mouse to steer, don't press Q or E, and don't auto level with O and you can get to your destination with a little effort.
     
    #20
    Last edited: Dec 20, 2019

Share This Page