Fixed FPS drop when loading LOD players model in MP [00487]

Discussion in 'Fixed (Read Only)' started by Franco, Jul 13, 2020.

  1. Franco

    Franco Lieutenant

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    0
    Mode: ALL
    Mode: Dedicated Server Only
    MODIFIED PLAYFIELDS: No
    Reproducibility: Always using Geforce 1080, and 2080 whe encounter aplayer
    Severity: Major

    DESCRIPTION

    I have a dedicated server, and play, in the same pc since version 6.x without problems. Since Alpha 12.x, the game play at 60FPS (using vsync) BUT when I'm alone.
    1. If someone enter the dedicated server, and I walk toward him from far to close, every the FPS drops TO 1 or 2, and the it goes back to 60 using Geforce 1080 AND 2080. NO RELATED TO CONSTANT 12 FPS like on RADEON
    2. And every time someone open the TAB menu, the FPS goes to ZERO for 1 or 2 seconds, and then goes to 60 again. ITS UNPLAYABLE since every patch from ALPHA 12.
    3. I TRIED to setup all the graphics option to MINIMUM and MAXIMUM, with the same results!
    Tested versions
    • Alpha 11.5: PERFECT, no performance issues on any player
    • Alpha 12.0.1: cannot play, due to FPS issue
    • Alpha 12.1: cannot play, due to FPS issue
    • Alpha 12.2.1: cannot play, due to FPS issue
    • Alpha 12.3.x: cannot play, due to FPS issue
    • Stable 1.3.3: cannot play, due to FPS issue
    • Stable 1.5.2+:cannot play, due to FPS issue
    • Stable 1.7.4+:cannot play, due to FPS issue

    HOW TO REPRODUCE ALWAYS:
    1. Run dedicated server or multiplayer on the same PC
    2. Enter ALONE
    3. Fly all over the place: PERFECT FPS
    4. Let a friend enter the game.
    5. Every player have a "sphere" of 10-15 mts. Now, every time I go inside that sphere, the FPS goes to ZERO for a second, and the FPS counter display 30 because the drop down is so quick, but VERY noticeable drop to a total freeze.
      View attachment 81275
    6. Videos reproducing the problem:


    Dedicated server / My gameplay too (drops to 0 FPS every 5 or 10 seconds):
    • SETUP 2: In this PC can be reproduced but instead of 0 FPS, it goes to 30-40
    • Intel(R) Core(TM) i7-8700K CPU, RTX 2080.
    • dxdiag:
    • SETUP 3:
    • PC specs: Windows 11 pro 64 bits 21H2. AMD Ryzen 7 2700X, motherboard ASUS ROG CROSSHAIR VI HERO, 32Gb ram DDR4 3000mhz, Geforce 2080 OC, SSD 840 EVO 500Gb + Intel SSD 660p 1TB + HDD 2TB.
    • My PC dxdiag:
    EDITS:
    Here's some video reproducing the problem. It usually happens when I walk through certain points.
    Also reproducen with a RTX 2080.

    SAVE WORLD
    https://drive.google.com/open?id=1JWJyUd3VpOdI2pb0zdhUbu4oHr2CPGYT

    The GPU utilization goes to ZERO every time the FPS goes down, and the COPY utilization get a spike. NOTE THAT My GPU IS AT 50% ALMOST ALWAYS.
    [​IMG]
     
    #1
    Last edited: Feb 12, 2022
  2. Franco

    Franco Lieutenant

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    0
    every time the COPY made a high, GPU goes to low (zero) and the FPS goes to zero
     

    Attached Files:

    #2
  3. Franco

    Franco Lieutenant

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    0
  4. Franco

    Franco Lieutenant

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    0
    • SETUP 2: In this PC can be reproduced but instead of 0 FPS, it goes to 30-40
    • Intel(R) Core(TM) i7-8700K CPU, RTX 2080.
    • dxdiag:
     
    #4
  5. Franco

    Franco Lieutenant

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    0
    I tried to setup all the graphics option to MINIMUM and MAXIMUM, with the same results!
     
    #5
  6. Franco

    Franco Lieutenant

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    0
    Since alpha 12.x, on a AMD Radeon 580 (8 gb VRAM) the FPS max is 12-15.
    1. Tested on version 12.1, 12.2 and 12.3... 15 FPS max
    2. Running on low or max graphics settings is the same, 12-15 FPS top
    3. If I roll back to version 11.5 it runs PERFECTLY at MAX graphics setting (50-60 FPS because of vsync)

    IT affects single player and multiplayer

     
    #6
  7. Franco

    Franco Lieutenant

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    0
    HOW TO REPRODUCE ALWAYS:
    1. Run dedicated server or multiplayer on the same PC
    2. Enter ALONE
    3. Fly all over the place: PERFECT FPS
    4. Let a friend enter the game.
    5. Now, every time I go CLOSE to any player from, the FPS goes to ZERO for half a second, and the FPS counter display 30 because the drop down is so quick, but VERY noticeable drop to a total freeze.
    6. Aall players have a sphere of 10-15 meters (aprox). When I approach to that sphere, the FPS goes to 0. Every time I approach that sphere, the GPU utilization goes to ZERO, but CPU does not register any visible spike

    7. Videos reproducing the problem:

     
    #7
    Last edited: Aug 18, 2020
  8. Franco

    Franco Lieutenant

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    0
    I was playing a LOT ALONE. No issues at ALL with the Geforce 1080. 60FPS always with vsync.
    But when I start the server and someone enter my game, the issue start, like the videos, when I approach other players from "far"
     
    #8
  9. Pantera

    Pantera Administrator Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    3,414
    Likes Received:
    6,093
    I cannot reproduce a FPS drop as low as what you show but I do see a smaller one which will be looked into.
     
    #9
  10. Kassonnade

    Kassonnade Rear Admiral

    Joined:
    May 13, 2017
    Messages:
    2,816
    Likes Received:
    4,111
    There seems to be the same pattern (spikes down and up) on the ethernet switch, on the image in your first post, @Franco .
     
    #10
  11. Franco

    Franco Lieutenant

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    0
    If I stay far, the ethernet sometimes spike, but no FPS drop. The problem only occur when:

    1. Approach from far to close to any player.
    OR
    2. Open the inventory with tab
     
    #11
    Last edited: Aug 15, 2020
  12. Kassonnade

    Kassonnade Rear Admiral

    Joined:
    May 13, 2017
    Messages:
    2,816
    Likes Received:
    4,111
    It's clear it has nothing to do with graphics, because it would be consistent each time you approach the player.
     
    #12
  13. Franco

    Franco Lieutenant

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    0
    May be my English is not good enough (sorry, its not my mother language), but it does happen every time I approach a player, from certain distance. It seems to be triggered when suit LOD change.

    The second case, is other way to reproduce de massive FPS drop
     
    #13
  14. Comp625

    Comp625 Lieutenant

    Joined:
    Jul 24, 2020
    Messages:
    49
    Likes Received:
    77
    Can you post your Empyrion graphics settings? I have a Radeon as well (5700 XT) and also have "skips" whenever others are around me. But it's not as bad as in your recording.

    Also, what Radeon drivers are you running?
     
    #14
  15. Franco

    Franco Lieutenant

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    0
    Graphics configs are not relevant. I tested ALL to minimum, and ALL at ULTRA. Same results. Thats on NVIDIA.
    On Radeon, the 570 cannot play more than 13 FPS since alpha 12. On v11 I can play at 60 whit all at max.
     
    #15
  16. Franco

    Franco Lieutenant

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    0
    Just in case, this is my preferred configs, but tested on MIN and MAX. Same results
    upload_2020-8-14_20-56-13.png

    upload_2020-8-14_20-56-25.png
     
    #16
  17. Kassonnade

    Kassonnade Rear Admiral

    Joined:
    May 13, 2017
    Messages:
    2,816
    Likes Received:
    4,111
    Water is far more demanding than a player model and there is no fps change when looking at water/ turning, etc. A LOD change for the player model should be insignificant, so this is mostly not graphics-related. When graphics are affected, the fps slows down, here we see a sharp "stop" which shows that something is waiting in the background.

    In other words, if it was just a "graphics" problem then lowering the settings would make it disappear, seeing how fluid the gameplay is at higher settings when not in the "close to other player" context.
     
    #17
  18. Franco

    Franco Lieutenant

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    0
    Just realize that all players have a sphere of 10-15 meters (aprox). When I approach to that sphere, the FPS goes to 0. Every time I approach that sphere, the GPU utilization goes to ZERO, but CPU does not register any visible spike
    upload_2020-8-17_22-52-12.png

    1. This can be reproduced only using the Geforce 1080
    2. On the radeon 580, it cannot be reproduced
    3. On a Gefroce 2080, it can be reproduced but the slowdown does not goes to zero. It goes from 60 FPS to 50 for example.
     
    #18
    Last edited: Aug 18, 2020
  19. Comp625

    Comp625 Lieutenant

    Joined:
    Jul 24, 2020
    Messages:
    49
    Likes Received:
    77
    Weird.

    What Nvidia drivers are you running with the 1080?
    In the Nvidia Control Panel, do you have the 1080's Power setting set to Maximum Performance? Can you share what you have your other settings set at?
    What clock speed and fan profile are you using on the 1080? I've noticed Empyrion is sensitive to heat and fan speed changes, and it could be that momentary surge in clock/boost causes the drop as the card is adjusting itself.
     
    #19
  20. Franco

    Franco Lieutenant

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    0
    1. Latest drivers that Geforce Experience recommend
    2. Power setting set to performance. All other to default, except V-Sync on.
    3. I'm using the OC profile on the official overclocking application from the card. So the fan are louder than "normal".
    4. This is the only game with this problem... ALL other work just fine, without this kind of slowdown.
     
    #20

Share This Page