Fixed MP: "Fill All" button for ammunition deletes transferred ammo [00448]

Discussion in 'Fixed (Read Only)' started by ABYAY, Apr 4, 2022.

  1. ABYAY

    ABYAY Ensign

    Apr 4, 2022
    Likes Received:
    For more information see here Bug Report Template

    Build: v1.7.8 3720
    Mode: Survival
    Mode: Dedicated Server

    SERVER NAME: Reforged Eden 1_7 |PvPvE| by Fracture (With Astic's Scripts)
    SEED-ID: <Multiplayer server, so no Seed ID available that I could find.>

    If applicable:

    Reproducibility: Fairly consistent based on short-term tests, but variable results.
    Severity: Variable; depends on the vessel involved and ammunition transferred. In short, minor/major.

    Type: Global, Multiplayer, Resource Transfer

    Summary: "Fill All" button for ammunition deletes transferred ammo in MP.

    Description: It was requested that I submit this bug report here after having a head-on experience with it alongside my friend. To put it short, when using the "Fill All" button to fill up the ammunition of a craft/base while connected to a cargo container on another craft/base, the ammunition does a few different things:

    - The ammunition won't transfer at all, and nothing changes. Basically, Fill All button doesn't do anything.
    - The ammunition "supposedly" transfers, but when you check the craft's ammo box, nothing is there, and the ammo is gone from the initial box.
    - The ammunition transfers, but the UI doesn't update to show that ammo has transferred. Moreso, it only seems to transfer from a client view. Reconnection with the server after doing the transfer will remove the ammunition that was transferred, destroying them.

    Thus far with my tests I've not gotten this function to work properly in Multiplayer, but I've generally been limited on how much I can do this without supplies on a survival server that I can just throw away like nothing. I also took a deep read into the logs of a play session of my friend (the one who brought this issue to light to me to investigate,) and there is nothing that really stands out in the log as being a problem. I'll attach the log per protocol. For reference of timestamps, there was a disconnect around 7:30, but the ammunition stuff wasn't checked until about 7:53. Nothing in the log has details around that timeframe. I checked my own from my testing afterwards and again, nothing really stood out.

    I've not had any problems with this in Singleplayer, so I'm guessing this is relevant to a networking code issue. Even though Reforged Eden is involved, none of the content involved in this transfer looked to be related to that mod.

    Steps to Reproduce:
    1) Put ammunition into a storage container. In my scenario, it was in a container controller in a base.
    2) Connect your inventory to the storage container.
    3) Access the P menu (Control Panel) of another craft. In my scenario, it was a CV.
    4) Press the "Fill all" button beneath the ammunition.

    In my situation when I tried replicating it, the ammo count did not update at all on the Main window for the craft, but when I checked the controller it did have ammunition. For reference in the attached screenshots, we had recreated the 100 mk200 laser charges and put them in there manually. The ammo in question here are the 30x175mm rounds, though the one that my friend did, all of the ammo for that CV was involved and deleted. For me, the ammunition was appearing inside the box, though my friend did not see the ammo aside from the laser charges. We verified together through sharing one another's screens as well, and screenshots will be attached. I had him log out and back in thinking he was desynced with the server, but still didn't see the ammo. I logged out and back in, and I saw the ammo was gone. It seemed like what I was seeing was not synchronizing to the server.

    You may be wondering where the first oddity mentioned (nothing happens) takes a part in this. We tried replicating this to a small SV that only used the minigun turret ammo (forgot the name off the top of my head,) and it didn't seem to want to transfer whatsoever. It's something that will require more testing to iron out, but the above info details to the best of my ability the situation.

    Screenshots, Crash Logs, any other Relevant Information or Download links: Relevant information/screenshots I could get have been provided. Quick explanation for each screenshot in respect to their names:

    Empyrion-Galactic Survival Evolved Screenshot 2022.04.04 - - Taken at 8:48AM, this is after I used the "Fill All" button and checked the ammo box.

    Empyrion - Galactic Survival Screenshot 2022.04.04 -

    RE-1_7_1_2022-04-04_08-48-23 - This was taken by my friend at around the same exact time with the in-game screenshot tool. This is when he looked at the same exact box.


    Empyrion-Galactic Survival Evolved Screenshot 2022.04.04 - - Taken at 9:17AM, this was after I relogged and checked the same ammo box again. For disclaimer, the bullets in the connected chest were newly crafted and not there the whole time. From where we had this box sorted with items, the ammunition was always on the viewable area, and I made sure I triple-checked every box on each vessel, and the ammo in question was never found anywhere.

    Empyrion - Galactic Survival Screenshot 2022.04.04 -

    Log is from my friend's session when the first deletion of ammo was discovered, which again was around 7:53AM, and the log doesn't have any details of stuff happening there.

    This covers everything in this report. If there is a scenario in MP that direly needs to be tested in retrospect to this, I'll see what I can do if I can be given instructions.

    Attached Files:


Share This Page