Fixed SV thrusters torque problem [7311]

Discussion in 'Fixed (Read Only)' started by yukka69, May 12, 2020.

  1. 7thScar

    7thScar Ensign

    Joined:
    Sep 18, 2018
    Messages:
    20
    Likes Received:
    20
    Sorry to bug you again. I know you guys are busy so I did a little investigating. I determined that I can turn the problem on and off again at will by removing the neo-ore I was mining from the cargo cotnainer. The first image below shows the problem on witht he cargo container full of neo-ore. Then the problems goes away (meaning I get toque back!) if I remove the neo I mined from the cotnainer. At first I thought this might be a volume issue so I tested it a bit more. It's not. If I put that same amount of ice in the container it did not happen, I still had torque. If I put the same amount of cobalt int he container (meaning 2474, same as the neo) the torque goes back down to zero. I beleive there is an issue either with how weight affects torque. Note that thrust is affected a little between thse images but torque is affected way more. torque problem-on.jpg torque problem-off.jpg
     
    #21
  2. Lord Sapito

    Lord Sapito Lieutenant

    Joined:
    May 8, 2019
    Messages:
    83
    Likes Received:
    77
    Do Neo, Ice, and Cobalt have the same mass per unit? You might want to adjust your volumes based on mass and re-test Ice, it might be lighter than neo or cobalt. Just a thought.. there might be a specific amount of total cargo mass that triggers the issue..
     
    #22
  3. Pantera

    Pantera Administrator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    6,615
    Likes Received:
    6,215
    Weight doesn't appear to be the root problem it is with the vessel controller.
    As I said we are trying to release a fix asap for it.
     
    #23
  4. 7thScar

    7thScar Ensign

    Joined:
    Sep 18, 2018
    Messages:
    20
    Likes Received:
    20
    Another good theory ruind by a cold hard fact :/
     
    #24
    Pach and Germanicus like this.
  5. jbrown

    jbrown Commander

    Joined:
    Jul 11, 2019
    Messages:
    98
    Likes Received:
    107
    Was adventuring on a lava planet, parked the CV on the surface, and took an SV out to make some trouble. Came back to the CV, unloaded my booty, and went to take off and BLAM, I cannot use the mouse to turn or maneuver the ship at all.

    Not sure what was up, I tried turning on and off the thrusters from various places in the ship, from the captain's seat and not, etc. I flew to space on the lift thrusters, to see if changing playfields would fix it. Then finally noticed on the P menu that it showed 0 degrees of rotation on any axis.

    The roll pitch and yaw is a COMBINATION of RCS and thrusters. I have no RCS on this ship. I have 4 forward, back, down and up thrusters, and 2 on each side. It's been fine for days since the launch of Alpha 12.4, and suddenly it doesn't work.

    Once the constructor finishes the large optronic Bridge it is working on, I will try reloading (this is a multi-player dedicated server). I can't do it while constructing, as that's another bug I noticed... I've lost all materials for 2 optronic bridges so far. With many things I'll queue up construction before logging and when I log back in, it's done for me. But, with those items, they just poofed. All resources were spent, but no bridges. So, now I babysit those.

    -----

    So logging out and quitting then loading back in worked, and the ship can move again??
     
    #25
  6. Pantera

    Pantera Administrator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    6,615
    Likes Received:
    6,215
    As of B2919 any vessel that still has 0 for yaw, pitch & roll can you please take them into creative mode &:

    1) Create a backup copy of the original BP
    2) Remove 1 thruster from each direction
    3) Check with the stats window & check if the yaw, pitch & roll have gone back above 0
    4) If they stay at 0 remove 1 more thruster from each direction & check the stats window again
    5) Repeat this until the yaw, pitch & roll have gone back above 0

    If anyone sees the pop up "Ship too Heavy" repeatedly appear consider it known & there is no need to report it.
     
    #26
    Germanicus and Pach like this.
  7. FionnMacCumhaill

    FionnMacCumhaill Commander

    Joined:
    Aug 9, 2019
    Messages:
    104
    Likes Received:
    40
    Sadly not 100% working this fix . Made new BP Removed about 10 thrusters to get yaw etc. back. Started adding them back in, again, hit 0 yaw/roll pitch again. I've attached the BP with the bottom opened and a message to show where thrusters should be placed. BP is attached, add two more thrusters in that location and it will break again immediately.

    Tried adding thrusters to random places. Could add more (16 in fact), but then hit a point where BP reduced to 0 y/p/r again (picture attached)

    Did all the above in a new creative game post update btw.
     

    Attached Files:

    #27
  8. Pantera

    Pantera Administrator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    6,615
    Likes Received:
    6,215
    Will look at it some most other vessels that had are not fine just a few appear not to be for some reason.
    I'll update here again soon.
     
    #28
    FionnMacCumhaill, Pach and Germanicus like this.
  9. Pantera

    Pantera Administrator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    6,615
    Likes Received:
    6,215
    A fix for this specifically will be available in one of the next releases.
     
    #29
    Pach, FionnMacCumhaill and Germanicus like this.
  10. 7thScar

    7thScar Ensign

    Joined:
    Sep 18, 2018
    Messages:
    20
    Likes Received:
    20
     
    #30
  11. Khazul

    Khazul Captain

    Joined:
    Jan 15, 2020
    Messages:
    890
    Likes Received:
    1,266
    Version 2.4.2 (2921)

    Mode: Creative, Survival, Freedom mode)
    Mode: Singleplayer

    SEED-ID: 534437

    If applicable:
    MODIFIED PLAYFIELDS: No

    Reproducibility: Always
    Severity: Major

    Type: RCS/Thrust, SV, HV, Torque

    Summary: Two vessel with zero torque - worked fine in 2.4.1

    Description: Attached are two near identical vessels, one HV, one SV - both now have zero torque. One (the SV) has been messed with to add additional thrusters and RCS to see if that would help - it did not.

    Update: it seems that games created in a previous version are OK where the vessel is already present. Its is only when I spawn in the vessel in this patch where I get the issue. I have a game with two copies of a vessel - one spawned in previous patch, one spawn in this patch. The one spawned in this patch doesn't work, but the other does.

    Game zipped at https://www.dropbox.com/s/20xypy4w4ye4w7h/Buggy SV HV NewGame_66-200529-0707.zip?dl=0


    Steps to Reproduce: sbp, then spawn them, fuel up, jump in, try to turn. Also look at P, statistics panel, torque (see screenshots). I have pasted in other vessels and they are fine (so far).
     

    Attached Files:

    #31
    Last edited: May 29, 2020
  12. Pantera

    Pantera Administrator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    6,615
    Likes Received:
    6,215
    @All In one of the next releases spawn in a fresh copy of the original BP & make sure the sliders for the "Rotation Sensitivity" at not at 0 if they are move them up to 1 then overwrite the blueprint again.

    Yaw, pitch & roll HV test_2020-05-29_14-00-55.png

    To note here "Rotation Sensitivity" sliders are now saved in blueprints so you can set them to any value you lie then overwrite the BP or create a new one & when you spawn them in again the sliders will maintain where you positioned the sliders.
     
    #32
    Khazul and Germanicus like this.
  13. Lobber

    Lobber Ensign

    Joined:
    Jan 11, 2017
    Messages:
    5
    Likes Received:
    9
    When you toggle thrusters off and back on again
    My CV Bumblebee had the sensitivity down to zero, but moving that up again didn't restore the turning ability of the ship. I also recorded a vid of it happening
     
    #33
  14. Pantera

    Pantera Administrator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    6,615
    Likes Received:
    6,215
    Please retest when the next fix is released.
     
    #34
    Germanicus likes this.
  15. jbrown

    jbrown Commander

    Joined:
    Jul 11, 2019
    Messages:
    98
    Likes Received:
    107
    There was a bug in the previous build that would cause pitch, yaw and roll to reset to 0, making your ship paralyzed. A complete server restart was required to fix this, and it could happen at any time upon changing playfields.

    Well, it's not fixed. Not exactly. It's no longer reverting to 0, but the calculations are still getting locked in a corrupt, bad setting.

    My CV isn't the most maneuverable but had +20 or better on pitch and roll and yaw. No RC, but thrusters placed at the four corners, giving maximum spread.

    Upon landing on a planet to collect from auto miners, that all went bonkers. Now, roll is at +61, making it super twitchy, and pitch and yaw are both +3 and +4 respectively, making it take 10 minutes to turn.

    Changing playfields did not restore it. Logging out and back in did not restore it. I'll have to wait for the server admin to reset the server to fix it, and of course it could break at any playfield change.

    As it stands, I honestly don't trust flying around, which is a shame, since that's kinda core to gameplay. Hope this can get fixed. I mind the error less than the lock. Meaning, if it once in a while went bonkers but relogging or changing playfields fixed it, well, at least that would be something. But, instead, it just dies, and the entire server becomes unplayable. Frequently.
     
    #35
  16. jbrown

    jbrown Commander

    Joined:
    Jul 11, 2019
    Messages:
    98
    Likes Received:
    107
    Glad to hear the devs are on the case. reading through this thread, I've noted a couple of things to add. First, my own ship's pitch and yaw problem happened specifically after picking up some neodynium, so maybe there is in fact a problem there? I'm NOWHERE near my ship's weight limit, and my top speed has not changed (as it would if i was overweight). I've flown in low and high and zero gravity during this bug.

    I've not gone back to the station to unload, but will test that. Thing is, I need my admin to do a complete server restart. Another bug (will post elsewhere) happened. Upon loading into a moon's playfield, my game crashed. Coming back, all four ships docked on my CV vanished. Oh, they're still there. About 2 kilometers BEHIND my ship. They still think they're docked, just trailing two kilometers behind. Changing playfields leaves them there. Sometimes ship translocation is fixed on a server reset, so hoping when he gets back and is able, that will fix it. That will also fix my pitch and yaw most likely. I've carried lots of neodynium yesterday without any problems. But, if not, I'll see if unloading it helps.

    It's entirely possible there's something wonky in the database regarding neo and weight, causing it to muck up the calculation for pitch and yaw.

    Oh, I also turned off whole blocks of engines, causing pitch and yaw to go to 0, then turned them back on, to see if merely redoing the calc would fix it. It didn't. So, something else (the neo, or a corruption) is borking that calculation.
     
    #36
  17. jbrown

    jbrown Commander

    Joined:
    Jul 11, 2019
    Messages:
    98
    Likes Received:
    107
    Okay, adding to this. I reported that, the other day my CV suddenly developed an issue with pitch and yaw (but not roll), both going from the +40-+60 range, down to +4 and +5 respectively. I'd just picked up a load of Neodynium and thought maybe that was it?

    Nope, found the problem. It's silly, and a bug, but not this bug.

    Somehow, loading into that playfield, the ships docked on my carrier became dislodged, and were about a kilometer behind the ship. All still "docked" but, trailing behind. I thought that had happened during a playfield change crash AFTER I noticed the pitch and yaw broken, but, nope, it must have been the cause.

    We updated to 12.5, did a total reset of the server, and nothing fixed. So, I manually went out and collected my ships, collecting the 3 SVs in space, then landing on a planet to get the HV tank. Once everything was back inside the carrier, magically, my pitch and yaw went back to their normal +40-+60 numbers.

    Clearly what happened was, the other ships being docked in my ship changed the calculation for ship size, or engine displacement. Suddenly my engines, nicely spread around the hull of the carrier, appeared to all be grouped in the very front. This explains the pitch and yaw, and also why the roll didn't change. Looking down the centerline, nothing had changed as far as the scale of the ship, or spread of the engines, but looked at from profile or above/below, taking into account the docked vessels a kilometer behind, the ship appeared huge with engines clumped on one side.

    So... problem fixed, and I can't say that any part of the pitch and roll were ever technically "broken" though this whole issue of docked things not being where they're supposed to be is a bit obnoxious ;-).
     
    #37
  18. Paganizer

    Paganizer Commander

    Joined:
    Jul 5, 2018
    Messages:
    135
    Likes Received:
    147
    i'd just like to add, I also have a HV with 0's all around. The HV in question has the issue both in creative and in survival. The 12.5 fix didn't seem to fix it.
     
    #38
  19. Pantera

    Pantera Administrator
    Staff Member

    • Developer
    • Moderator
    Joined:
    Aug 15, 2016
    Messages:
    6,615
    Likes Received:
    6,215
    You are going to need to supply a blueprint so we have something to look at.
     
    #39
    Pach likes this.
  20. Paganizer

    Paganizer Commander

    Joined:
    Jul 5, 2018
    Messages:
    135
    Likes Received:
    147
    you mean steam upload and share the link?
     
    #40

Share This Page